Bug 1015725 - German keyboard-layout - "tilde" doesn't work as "dead key"
German keyboard-layout - "tilde" doesn't work as "dead key"
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: xkeyboard-config (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-04 19:40 EDT by Alex. H. F.
Modified: 2013-11-18 00:14 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-01 00:42:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex. H. F. 2013-10-04 19:40:30 EDT
Description of problem:
Using German keyboard-layout: "Deutsch"
Typing accented characters "tilde" does not act as "dead key". All other characters work as expected.


Version-Release number of selected component (if applicable):
Fedora 19 faulty
Fedora 18 worked properly

How reproducible:
Always

Steps to Reproduce:
1. Be sure actual keyboard-mapping is "German"
1. Using any text editing application/text field/terminal
2. Type "AltGr" + "~"
3. "~" appears instantly, no dead key

Actual results:
can't generate tilde-accented letters, since tilde is no dead key

Expected results:
German keyboard-layout should have tilde as dead key.

Additional info:

Any workaround to overcome the issue, and give me a way to to type following accented characters?

~a ~o ~n
Comment 1 Alex. H. F. 2013-10-05 10:59:18 EDT
Found a way to overcome the problem. It isn't the solution thou:

For Gnome: Eintellungen [Settings]
--> Region und Sprache [region and language]
   --> Eingabequellen
      --> +
         --> im Suchfeld "veraltet" eingeben [enter "outdated" in search-field]
             aus der Liste "Deutsch (veraltet)" auswählen. [from the List choose (outdated)]

Done!

Furthermore, this bug isn't solved.
There must be checked:

1) why the german keymapping (dead-tilde) has been changed.
2) give a "simple" way of choosing the "old-fashioned" german keymapping.

Thanks and regards
Comment 2 Alex. H. F. 2013-10-06 06:59:27 EDT
Additionally, I feel we must define "German Latin 1" mapping.
Could someone point us to a definition?

Please, keep in mind the most spoken "Latin languages":

French, Spanish, Portuguese, Italian, Romanian, etc.

Here I found a definition for the Unicode block "latin 1":
http://en.wikipedia.org/wiki/ISO/IEC_8859-1

If one needs a "pure" German keyboard-mapping, he should choose "German (no dead-keys)".
Comment 3 Peter Hutterer 2013-11-01 00:42:23 EDT
Please see the upstream discussion on that topic

https://bugs.freedesktop.org/show_bug.cgi?id=9752
Comment 4 Alex. H. F. 2013-11-01 10:20:27 EDT
No understanding of matter
No efforts to correct bad implementations
No solution

Why not following:

German - WITH DEADKEYS
German (pure, with NO deadkeys at all)

No "legacy" strange solution AT ALL!!!
Comment 5 Peter Hutterer 2013-11-11 20:01:21 EST
again, please see the upstream discussion. we don't patch this in fedora because we'd be incompatible to everyone else. if you want to change it please request that upstream in the bug I linked to but quite frankly, I don't see the need, we're just arguing about how it's being named here. note that no dead keys is different to changing just the tilde key. and the change got us in line with the DIN 2137 and Windows, which is not to be sneezed at.
Comment 6 Alex. H. F. 2013-11-12 07:42:36 EST
When you tell me you are following DIN 2137, you show me that you in fact doesn't know WHAT you are talking about.

DIN 2137 - describes the physical keyboard-layout and NOT its functionality.
Windows has ever been wrong. For that I created my own keyboard-kaguage-setup (Latin for German-kayboard) which works fine at least for "pt" and "es".

What I would expect from you, is to act at the "upstream" to correct the ever existing misbehavior of this matter.

A pure German-layout for German writting does not need any accent (or dead-key) functionality.
To write a Latin-language on a German-Layout YES.

The problem is "most Germans" doesn't have a clue about this subject at all.

Many thanks.
Comment 7 Peter Hutterer 2013-11-14 00:06:37 EST
(In reply to careca from comment #6)
> DIN 2137 - describes the physical keyboard-layout and NOT its functionality.

http://de.wikipedia.org/wiki/T2_%28Tastaturbelegung%29
"Tottasten für diakritische Zeichen sind durch schmale Rechtecke markiert, die auch die Lage des diakritischen Zeichens zum Grundbuchstaben markieren."
yeah, it's wikipedia but I don't have access to the actual DIN paper.

(In reply to careca from comment #6)
> What I would expect from you, is to act at the "upstream" to correct the
> ever existing misbehavior of this matter.

no. I'm the maintainer for xkeyboard-config in Fedora but these things need to be discussed at the upstream. So again, please go there and discuss this with the maintainers, I'm not playing the proxy here.
Comment 8 Alex. H. F. 2013-11-14 05:08:57 EST
Ok, I will act in the upstream discussion. thanks.
But, be sure you will come to work on this topic again.

I contacted the responsible person at DIN questioning on the changes they made to the norm (DIN 2137-2) where they "changed the behavior of "tilde" to a "non diacritic key (no dead-key).
Maybe they transfered this functionality to DIN 2137-3. But, this I want to hear from him.

By the way, regardless of the norm describing the "tilde-behaviour", I can't understand why anyone named the "still" existing mapping as "German (legacy)".

What will happen next? Will YOU delete it from the Linux distributions?

Thanks for your collaboration.
Comment 9 Peter Hutterer 2013-11-18 00:14:05 EST
(In reply to careca from comment #8)
> By the way, regardless of the norm describing the "tilde-behaviour", I can't
> understand why anyone named the "still" existing mapping as "German
> (legacy)".

fwiw, "legacy" is IMO not the same as "veraltet" which is what the german translation suggests. "veraltet" would be "outdated" in english. I'm not sure there's a good german translation for "legacy", at least I can think of one. naming the previous layout "legacy" is quite natural in English though.

> What will happen next? Will YOU delete it from the Linux distributions?

no, again, please resolve this upstream and we'll handle it in Fedora as it is upstream.

Note You need to log in before you can comment on or make changes to this bug.