Bug 101575 - Timezone Configuration doesn't work with Text Mode Setup Utility 1.13
Timezone Configuration doesn't work with Text Mode Setup Utility 1.13
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-date (Show other bugs)
3.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Brent Fox
David Lawrence
:
Depends On:
Blocks: 101028
  Show dependency treegraph
 
Reported: 2003-08-04 06:04 EDT by Paul McWatt
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-29 16:41:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul McWatt 2003-08-04 06:04:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
If you use the Text Mode Setup Utility, selecting Timezone configuration does 
nothing. If you then exit the Setup Utility keystrokes are not echoed to the 
screen. You need to exit and login again to resume normality.

I'm using an IBM x220 server, Savage4 video, and a 9513 TFT monitor.
I get the symtoms above if i use a text console or a terminal under Gnome X-
Windows.

The rest of the functions of the Setup Utility work okay and exit cleanly. 


Version-Release number of selected component (if applicable):
Text Mode Setup Utility 1.13

How reproducible:
Always

Steps to Reproduce:
1. Type setup to enter the Setup Tool
2. Select Timezone Configuration
3. Select Exit
    

Actual Results:  Timezone configuration does nothing.
Keystrokes are not echoed to the screen once you exit the tool.

Expected Results:  Selecting Timezone configuration should produce another 
screen where i set the timezone. Exiting the tool should allow me to see what i 
am typing in a terminal or console. 

Additional info:
Comment 1 Harald Hoyer 2003-08-14 09:55:37 EDT
worksforme... which languange do you have set?
$ echo $LANG
Comment 2 Paul McWatt 2003-08-14 10:03:58 EDT
en_GB.UTF-8
This is intentional as i'm in the UK.
If you like i can re-install with the US and retest.
Comment 3 Nalin Dahyabhai 2003-08-25 10:50:26 EDT
I can't reproduce this here in en_US.UTF-8 or en_GB.UTF-8.  Please attach the
list of installed packages (output of 'rpm -qa' should be enough, and if needed,
feel free to prune anything out which isn't included in Taroon) so that I can
verify that this isn't happening due to a missing dependency.
Comment 4 Nalin Dahyabhai 2003-08-25 14:32:35 EDT
Retested, installed B1 with 'minimal' option, selected en_US and en_GB as
supported locales, installed redhat-config-date, ntp, and libcap.  WorksForMe in
both LANGs.
Comment 5 Paul McWatt 2003-08-26 11:53:54 EDT
I previously installed on three IBM x220 servers.
I re-installed today on an IBM x440 server believing it to possibly be some 
BIOS/APIC problem..?? - but i got the same problem with the x440 and only 
taroon packages. I have the output of rpm-qa in a file or i can cut'n paste it 
here...let me know.
Comment 6 Paul McWatt 2003-08-27 06:21:57 EDT
Did some more testing this morning - in the above examples i am using 'setup' 
from a command line to try and use the Timezone Config. If i use the GUI it 
works fine. If i then go to the command line again - this also now works fine.
I did this on all 4 machines and all 4 work okay only after using the GUI tool.
Comment 7 Nalin Dahyabhai 2003-08-27 09:47:44 EDT
Indeed, firstboot came up immediately after the install and set the date.  I'll
reinstall and bypass firstboot to see if it can be reproduced.
Comment 8 Nalin Dahyabhai 2003-08-27 10:38:36 EDT
I must be confused due to having reinstalled B1 too many times -- firstboot does
not come up in a minimal install because it isn't installed.

Does invoking /usr/sbin/timeconfig directly in situations where running it from
setup doesn't work produce any error messages?
Comment 9 Paul McWatt 2003-08-28 04:19:59 EDT
I built another system using only taroon beta1. Confirmed using setup from 
cmdline didn't work. I then ran /usr/sbin/timeconfig and received the following 
information:

Traceback (most recent call last):
                                    File "/usr/share/redhat-config-date/timeconf
ig.py", line 102, in ?
                          rc = TimezoneWindow()(screen, zonetab, timezoneBackend
)
   File "/usr/share/redhat-config-date/timeconfig.py", line 56, in __call__
                                                                               l
.setCurrent(self.default)
                           File "/usr/lib/python2.2/site-packages/snack.py", lin
e 100, in setCurrent
                        self.w.listboxSetCurrent(self.item2key[item])
                                                                     KeyError: G
B
 [root@node3 root]#
Comment 10 Paul McWatt 2003-08-28 09:57:38 EDT
I installed RH9.0 with 2.4.20-18.9 kernel on my laptop 2 days ago and i have 
just noticed that this does the exact same thing. Timezone under setup doesn't 
work. /usr/sbin/timezoneconfig gives the same error as above. If i use the GUI 
it works okay and then using setup works okay.
Comment 11 Nalin Dahyabhai 2003-08-29 14:55:10 EDT
Thanks for the traceback -- it was exactly what I needed.  I'm pretty sure this
happens when redhat-config-date and anaconda disagree on what the set of valid
timezone names is, and anaconda sets one in /etc/sysconfig/clock which
redhat-config-date doesn't see in /usr/share/zoneinfo/zone.tab.  This explains
why I couldn't reproduce it on a system in the America/New_York timezone.
Comment 12 Brent Fox 2003-08-29 15:01:39 EDT
Changing component to redhat-config-date.
Comment 13 Brent Fox 2003-08-29 16:41:33 EDT
Ah, ok.  I think we've found the root of the problem.  

For some reason, the text mode installer presents more timezones than the gui
installer does.  The gui installer and redhat-config-date only present the zones
that are listed in the zone.tab file whereas the tui installer presents all the
zone.tab entries as well as some additional zones.  "GB" is one of these extra
zones.  

I'm guessing that you did the system installation with the text mode installer
since that seems to be the only way to pick the "GB" zone.  The gui installer
would have presented "Europe/London" instead of "GB".  Since timeconfig didn't
find "GB" in the zone.tab file, it was crashing.

There are two parts to the solution here.  

1) Change the text mode installer to use the same timezone list as everything
else.  The installer team is making this change at the moment.

2) Add a check to timeconfig to make sure the timezone is in the zone.tab file.
 If the timezone is not found in the list, it will default to
"America/New_York".  This allows timeconfig to avoid crashing if an invalid
timezone is found in /etc/sysconfig/clock.  I am adding this change now and the
fix should appear in redhat-config-date-1.5.19-1.

Note You need to log in before you can comment on or make changes to this bug.