Bug 1015761 - [abrt] obapps-0.1.7-5.fc19: _controls.py:4560:GetItem:TypeError: in method 'ListCtrl_GetItem', expected argument 2 of type 'long'
[abrt] obapps-0.1.7-5.fc19: _controls.py:4560:GetItem:TypeError: in method 'L...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: obapps (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: James Wrigley
Fedora Extras Quality Assurance
abrt_hash:dd4dd418ee4bf0cd8bf16e90f08...
:
Depends On:
Blocks: 1016441
  Show dependency treegraph
 
Reported: 2013-10-05 03:44 EDT by James Wrigley
Modified: 2014-09-08 17:52 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-08 17:52:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (799 bytes, text/plain)
2013-10-05 03:44 EDT, James Wrigley
no flags Details

  None (edit)
Description James Wrigley 2013-10-05 03:44:54 EDT
Description of problem:
I ran my build of obapps, added a menu item, and was editing the 'Class' section when the error occurred.

Version-Release number of selected component:
obapps-0.1.7-5.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /usr/bin/obapps
dso_list:       wxPython-2.8.12.0-4.fc19.x86_64
executable:     /usr/bin/obapps
kernel:         3.11.2-201.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1002

Truncated backtrace:
_controls.py:4560:GetItem:TypeError: in method 'ListCtrl_GetItem', expected argument 2 of type 'long'

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14656, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/bin/obapps", line 168, in set_model_values
    self.model.Set(name,self.list.GetItem(sel,i).GetText())
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_controls.py", line 4560, in GetItem
    val = _controls_.ListCtrl_GetItem(*args, **kwargs)
TypeError: in method 'ListCtrl_GetItem', expected argument 2 of type 'long'

Local variables in innermost frame:
args: (<__main__.AWListCtrl; proxy of <Swig Object of type 'wxPyListCtrl *' at 0x319ecd0> >, None, 0)
kwargs: {}
Comment 1 James Wrigley 2013-10-05 03:44:58 EDT
Created attachment 808083 [details]
File: backtrace
Comment 2 James Wrigley 2013-10-08 04:13:40 EDT
Bug reported to upstream.
Comment 3 James Wrigley 2014-09-08 17:52:40 EDT
Seems to be abandoned upstream, so closing this.

Note You need to log in before you can comment on or make changes to this bug.