Bug 1015787 - missing EclipseFileManager
missing EclipseFileManager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ecj (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-05 08:28 EDT by gil cattaneo
Modified: 2014-01-12 19:28 EST (History)
5 users (show)

See Also:
Fixed In Version: ecj-4.2.1-9.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-10 01:24:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
http://koji.fedoraproject.org/koji/taskinfo?taskID=6041231 (2.78 KB, application/x-octet-stream)
2013-10-09 08:48 EDT, gil cattaneo
no flags Details
enable build of org/eclipse/jdt/internal/compiler/[apt,tool] (2.78 KB, application/x-octet-stream)
2013-10-09 08:50 EDT, gil cattaneo
no flags Details

  None (edit)
Description gil cattaneo 2013-10-05 08:28:48 EDT
hi
any reasons for not ship 
org.eclipse.jdt.internal.compiler.apt.util.EclipseFileManager
and
org.eclipse.jdt.internal.compiler.tool.EclipseFileManager
(and all org/eclipse/jdt/internal/compiler/apt 
org/eclipse/jdt/internal/compiler/tool classes)
in ecj jar?
regards
Comment 1 Andrew Overholt 2013-10-08 11:21:49 EDT
Are these in ecj.jar as shipped from eclipse.org?
Comment 2 gil cattaneo 2013-10-08 11:33:10 EDT
hi
aren't availables in 
/usr/lib*/eclipse/plugins/org.eclipse.jdt.core_*.jar
i done these changes in your spec file:
%build
%if %{with_gcjbootstrap}
# Remove bits of JDT Core we don't want to build
  rm -r org/eclipse/jdt/internal/compiler/tool
  rm -r org/eclipse/jdt/internal/compiler/apt
  rm -f org/eclipse/jdt/core/BuildJarIndex.java
  for f in `find -name '*.java' | cut -c 3- | LC_ALL=C sort`; do
    gcj -Wno-deprecated -C $f
  done

  find -name '*.class' -or -name '*.properties' -or -name '*.rsc' |\
    xargs fastjar cf %{name}-%{version}.jar

%else
   ant
%endif
seem with gcj build fails...
regards
Comment 3 Krzysztof Daniel 2013-10-09 02:50:59 EDT
Hey,

the question was if they are shipped in the standalone eclipse compiler (see the JDT Core Batch Compiler http://download.eclipse.org/eclipse/downloads/drops4/S-4.4M2-201309182000/).

This is different from eclipse jdt plugin and ships different classes (mostly because some functionality is not required in a standalone compiler, like f.e. indexing).

Now, if Eclipse ecj and Fedora ecj differ, then it is necessary to reexamine the packaging. Patches are welcome!
Comment 4 gil cattaneo 2013-10-09 08:48:25 EDT
Created attachment 809894 [details]
http://koji.fedoraproject.org/koji/taskinfo?taskID=6041231

- enable build of org/eclipse/jdt/internal/compiler/[apt,tool]
  (ant build mode only), required by querydsl
- remove some rpmlint problems (invalid date)

Task info: http://koji.fedoraproject.org/koji/taskinfo?taskID=6041231
Comment 5 gil cattaneo 2013-10-09 08:50:41 EDT
Created attachment 809895 [details]
enable build of org/eclipse/jdt/internal/compiler/[apt,tool]
Comment 6 Fedora Update System 2013-10-10 03:42:57 EDT
ecj-4.2.1-9.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/ecj-4.2.1-9.fc20
Comment 7 Fedora Update System 2013-10-11 12:52:57 EDT
Package ecj-4.2.1-9.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ecj-4.2.1-9.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18902/ecj-4.2.1-9.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-11-10 01:24:39 EST
ecj-4.2.1-9.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.