Bug 1015832 - [abrt] rtorrent-0.9.3-5.fc19: handle_sigbus: Process /usr/bin/rtorrent was killed by signal 6 (SIGABRT)
[abrt] rtorrent-0.9.3-5.fc19: handle_sigbus: Process /usr/bin/rtorrent was ki...
Status: CLOSED DUPLICATE of bug 1011304
Product: Fedora
Classification: Fedora
Component: rtorrent (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Conrad Meyer
Fedora Extras Quality Assurance
abrt_hash:901a84544aa471797f67cc5de03...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-05 19:34 EDT by striker.pena
Modified: 2013-10-05 22:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-05 22:25:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (17.44 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: cgroup (141 bytes, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: core_backtrace (9.21 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: dso_list (4.24 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: environ (3.03 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: limits (1.29 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: maps (38.62 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: open_fds (17.13 KB, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: proc_pid_status (938 bytes, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details
File: var_log_messages (229 bytes, text/plain)
2013-10-05 19:34 EDT, striker.pena
no flags Details

  None (edit)
Description striker.pena 2013-10-05 19:34:16 EDT
Description of problem:
I was using rtorrent in terminal

Version-Release number of selected component:
rtorrent-0.9.3-5.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        rtorrent
crash_function: handle_sigbus
executable:     /usr/bin/rtorrent
kernel:         3.11.2-201.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 handle_sigbus at main.cc:949
 #4 __memcpy_ssse3 at ../sysdeps/x86_64/multiarch/memcpy-ssse3.S:2164
 #5 memcpy at /usr/include/bits/string3.h:51
 #6 torrent::Chunk::from_buffer at chunk.cc:240
 #7 torrent::PeerConnectionBase::down_chunk_process at peer_connection_base.cc:587
 #8 torrent::PeerConnectionBase::down_chunk_from_buffer at peer_connection_base.cc:529
 #9 read_message at peer_connection_leech.cc:296
 #10 torrent::PeerConnection<(torrent::Download::ConnectionType)0>::event_read at peer_connection_leech.cc:390
 #11 torrent::PollEPoll::perform at poll_epoll.cc:180
 #12 torrent::PollEPoll::do_poll at poll_epoll.cc:210
Comment 1 striker.pena 2013-10-05 19:34:19 EDT
Created attachment 808322 [details]
File: backtrace
Comment 2 striker.pena 2013-10-05 19:34:21 EDT
Created attachment 808323 [details]
File: cgroup
Comment 3 striker.pena 2013-10-05 19:34:23 EDT
Created attachment 808324 [details]
File: core_backtrace
Comment 4 striker.pena 2013-10-05 19:34:26 EDT
Created attachment 808325 [details]
File: dso_list
Comment 5 striker.pena 2013-10-05 19:34:28 EDT
Created attachment 808326 [details]
File: environ
Comment 6 striker.pena 2013-10-05 19:34:30 EDT
Created attachment 808327 [details]
File: limits
Comment 7 striker.pena 2013-10-05 19:34:34 EDT
Created attachment 808328 [details]
File: maps
Comment 8 striker.pena 2013-10-05 19:34:36 EDT
Created attachment 808329 [details]
File: open_fds
Comment 9 striker.pena 2013-10-05 19:34:38 EDT
Created attachment 808330 [details]
File: proc_pid_status
Comment 10 striker.pena 2013-10-05 19:34:41 EDT
Created attachment 808331 [details]
File: var_log_messages
Comment 11 Conrad Meyer 2013-10-05 22:25:19 EDT

*** This bug has been marked as a duplicate of bug 1011304 ***

Note You need to log in before you can comment on or make changes to this bug.