Bug 1015849 - [SOLVED] Atheros QCA8171 Gigabit Ethernet does not work on 64 bit fc19, no fix/workaround/documentation/anything available
[SOLVED] Atheros QCA8171 Gigabit Ethernet does not work on 64 bit fc19, no fi...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 02:16 EDT by Martin Ellison
Modified: 2013-10-06 04:28 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 04:28:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Ellison 2013-10-06 02:16:51 EDT
Description of problem:

Qualcomm Atheros QCA8171 Gigabit Ethernet adaptor does not work and no documentation avavilable on how to fix


Version-Release number of selected component (if applicable):

This is on current 64 bit Fedora i.e. Linux 3.9.5-301.fc19.x86_64


How reproducible:

consistent


Steps to Reproduce:
1. install ethernet card
2. connect ethernet to computer
3. try to connect to internet

Actual results:

device does not appear in network manager

Expected results:

can create internet connection using network manager


Additional info:

have tried to install alx driver from somewhere called backports or compat drivers, but build fails with missing directory error. I have installed kernel headers and kernel devel but this does not seem to work.
Comment 1 Martin Ellison 2013-10-06 03:29:54 EDT
Specifically, when I try to build the driver, I get a build error like:

$ make
make -C /lib/modules/3.9.5-301.fc19.x86_64/build M=/home/martin/Downloads/compat39/compat-drivers-3.9-rc4-2-s modules
make: *** /lib/modules/3.9.5-301.fc19.x86_64/build: No such file or directory.  Stop.
make: *** [modules] Error 2

And when I investigate I get:

$ ls -l /lib/modules/3.9.5-301.fc19.x86_64/build
lrwxrwxrwx. 1 root root 38 Jun 28 01:14 /lib/modules/3.9.5-301.fc19.x86_64/build -> /usr/src/kernels/3.9.5-301.fc19.x86_64
$ ls -l usr/src/kernels/3.9.5-301.fc19.x86_64
ls: cannot access usr/src/kernels/3.9.5-301.fc19.x86_64: No such file or directory

I am at a loss as to how to proceed. I have tried several compat tarballs, but they all result in this error.

I realise that there are various bug reports and forum posts out there on this general issue, but none of them fix it for me, so I have raised this bug. The other reports/posts cover Ubuntu, or 32 bit systems, or just do not make sense.
Comment 2 Martin Ellison 2013-10-06 03:31:51 EDT
Sorry, read 
ls: cannot access usr/src/kernels/3.9.5-301.fc19.x86_64: No such file or directory
$ ls -l /usr/src/kernels/3.9.5-301.fc19.x86_64
ls: cannot access /usr/src/kernels/3.9.5-301.fc19.x86_64: No such file or directory
Comment 3 Martin Ellison 2013-10-06 04:28:24 EDT
OK, solved. Had to do with the fact that I had just installed the kernel headers and upgraded the kernel at the same time. Once I rebooted then the headers and the running version were lined up and the build worked.

Note You need to log in before you can comment on or make changes to this bug.