Bug 1015852 - ruby-wallaby requires unfullfilled ruby dependencies in @updates-testing
ruby-wallaby requires unfullfilled ruby dependencies in @updates-testing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wallaby (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Benton
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 04:38 EDT by Pablo Rodríguez
Modified: 2013-11-04 21:52 EST (History)
2 users (show)

See Also:
Fixed In Version: wallaby-0.16.4-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-04 21:52:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pablo Rodríguez 2013-10-06 04:38:13 EDT
Hi there,

here you have the error yumex throws when updating ruby-wallaby:

Dependency Resolution Errors:

Package: ruby-wallaby-0.16.3-2.fc19.noarch (updates-testing)
    Requires: ruby(abi) = 1.9.1Package: nss-devel-3.15.2-1.fc19.i686 (updates-testing)
    Requires: pkgconfig(nss-util) >= 3.15.2
    Installed: nss-util-devel-3.15.1-1.fc19.i686 (@updates)
        pkgconfig(nss-util) = 3.15.1
    Available: nss-util-devel-3.14.3-1.fc19.i686 (fedora)
        pkgconfig(nss-util) = 3.14.3Package: nss-3.15.2-1.fc19.i686 (updates-testing)
    Requires: nss-util >= 3.15.2
    Installed: nss-util-3.15.1-1.fc19.i686 (@updates)
        nss-util = 3.15.1-1.fc19
    Available: nss-util-3.14.3-1.fc19.i686 (fedora)
        nss-util = 3.14.3-1.fc19Package: nss-3.15.2-1.fc19.i686 (updates-testing)
    Requires: nss-softokn(x86-32) >= 3.15.2
    Installed: nss-softokn-3.15.1-1.fc19.i686 (@updates)
        nss-softokn(x86-32) = 3.15.1-1.fc19
    Available: nss-softokn-3.14.3-1.fc19.i686 (fedora)
        nss-softokn(x86-32) = 3.14.3-1.fc19

Just in case it helps,


Pablo
Comment 1 Will Benton 2013-10-07 10:01:12 EDT
Pablo, I believe you've pasted the report for two packages here and the problem for Wallaby is the spurious ruby(abi) requirement.  (0.16.3-2 shouldn't be the current version anyway; I submitted a 0.16.3-3 shortly after that, which should fix the bogus dependency.)

Do you see the same problem with 0.16.3-3?
Comment 2 Pablo Rodríguez 2013-10-07 12:18:23 EDT
Thanks Will.

I get this:

Dependency Resolution Errors:

Package: ruby-wallaby-0.16.3-2.fc19.noarch (updates-testing)
    Requires: ruby(abi) = 1.9.1Package: nss-devel-3.15.2-1.fc19.i686 (updates-testing)
    Requires: pkgconfig(nss-util) >= 3.15.2
    Installed: nss-util-devel-3.15.1-1.fc19.i686 (@updates)
        pkgconfig(nss-util) = 3.15.1
    Available: nss-util-devel-3.14.3-1.fc19.i686 (fedora)
        pkgconfig(nss-util) = 3.14.3Package: nss-3.15.2-1.fc19.i686 (updates-testing)
    Requires: nss-util >= 3.15.2
    Installed: nss-util-3.15.1-1.fc19.i686 (@updates)
        nss-util = 3.15.1-1.fc19
    Available: nss-util-3.14.3-1.fc19.i686 (fedora)
        nss-util = 3.14.3-1.fc19Package: nss-3.15.2-1.fc19.i686 (updates-testing)
    Requires: nss-softokn(x86-32) >= 3.15.2
    Installed: nss-softokn-3.15.1-1.fc19.i686 (@updates)
        nss-softokn(x86-32) = 3.15.1-1.fc19
    Available: nss-softokn-3.14.3-1.fc19.i686 (fedora)
        nss-softokn(x86-32) = 3.14.3-1.fc19

So it seems that my repository hasn’t updated yet.
Comment 3 Pablo Rodríguez 2013-10-14 12:42:19 EDT
Will,

just right now, yumex or yum don’t update to ruby-wallaby-0.16.3-2 (from @updates-testing)

The log from yumex:

Dependency Resolution Errors:

Package: ruby-wallaby-0.16.3-2.fc19.noarch (updates-testing)
    Requires: ruby(abi) = 1.9.1

What is wrong here? (Sorry, but I don’t have any clue.)


Many thanks for your help.
Comment 4 Will Benton 2013-10-14 12:59:28 EDT
Pablo, I submitted a request to push 0.16.3-3 to stable this morning.  This package does not have the ruby(abi) dependency.  After seeing your message, I also unpushed 0.16.3-2 from testing, so you shouldn't see it any more.
Comment 5 Pablo Rodríguez 2013-10-16 11:11:54 EDT
(In reply to Will Benton from comment #4)
> Pablo, I submitted a request to push 0.16.3-3 to stable this morning.  This
> package does not have the ruby(abi) dependency.  After seeing your message,
> I also unpushed 0.16.3-2 from testing, so you shouldn't see it any more.

Will, I’m afraid that yum or yumex only download ruby-wallaby-0.16.3-2.fc19.noarch from updates-testing repository.
Comment 6 Will Benton 2013-10-16 11:58:23 EDT
I guess we need to be patient and wait for it to make its way to stable, then:

https://admin.fedoraproject.org/updates/FEDORA-2013-18400/wallaby-0.16.3-3.fc19
Comment 7 Pablo Rodríguez 2013-10-16 16:08:18 EDT
Will,

I downloaded the binary and I got the following error:

rpm -Uhv ruby-wallaby-0.16.3-3.fc19.noarch.rpm 
error: Failed dependencies:
	ruby(release) = 1.9.1 is needed by ruby-wallaby-0.16.3-3.fc19.noarch

I don’t know whether this is relevant or not.

Many thanks for your help.
Comment 8 Fedora Update System 2013-10-17 13:33:17 EDT
wallaby-0.16.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/wallaby-0.16.4-1.fc19
Comment 9 Fedora Update System 2013-10-18 15:57:42 EDT
Package wallaby-0.16.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing wallaby-0.16.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19347/wallaby-0.16.4-1.fc19
then log in and leave karma (feedback).
Comment 10 Pablo Rodríguez 2013-11-03 14:52:03 EST
Sorry for not having answered before, Will.

Everything works fine now.
Comment 11 Fedora Update System 2013-11-04 21:52:56 EST
wallaby-0.16.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.