Bug 1015865 - docker build fails due to missing LOOP_CTL_GET_FREE in EL version of linux/loop.h
docker build fails due to missing LOOP_CTL_GET_FREE in EL version of linux/l...
Status: CLOSED UPSTREAM
Product: Fedora EPEL
Classification: Fedora
Component: docker-io (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 07:04 EDT by Lokesh Mandvekar
Modified: 2014-07-01 18:59 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 00:14:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2013-10-06 07:04:30 EDT
Description of problem: rpmbuild fails


Version-Release number of selected component (if applicable): 0.7-1.staging


How reproducible: Always


Steps to Reproduce:
1. run rpmbuild on docker-io spec file on EL6

Actual results:
# github.com/dotcloud/docker/devmapper
devmapper.go: In function 'attach_loop_device':
devmapper.go:29: error: 'LOOP_CTL_GET_FREE' undeclared (first use in this function)
devmapper.go:29: error: (Each undeclared identifier is reported only once
devmapper.go:29: error: for each function it appears in.)
error: Bad exit status from /var/tmp/rpm-tmp.iYm5vM (%build)


Additional info:

linux/loop.h in el6 doesn't seem to define LOOP_CTL_GET_FREE.
Comment 1 Aristeu Rozanski 2013-10-07 11:01:05 EDT
It looks like it's not only the definition missing, but on demand loop device
allocation.
upstream: 770fe30a46a12b6fb6b63fbe1737654d28e84844
Comment 2 Aristeu Rozanski 2013-10-07 11:05:15 EDT
(In reply to Aristeu Rozanski from comment #1)
> It looks like it's not only the definition missing, but on demand loop device
> allocation.
> upstream: 770fe30a46a12b6fb6b63fbe1737654d28e84844

I was told if the feature isn't available, docker will fall back to another
method. Please ignore my last comment.
Comment 3 Lokesh Mandvekar 2013-10-07 11:08:11 EDT
(In reply to Aristeu Rozanski from comment #2)
> I was told if the feature isn't available, docker will fall back to another
> method. Please ignore my last comment.

Thanks Aris. https://github.com/alexlarsson/docker/commit/323f3c2bc1566c5c66e4ba49f760030f2c5adae0 via Alex. Should be merged upstream soon.
Comment 4 Lokesh Mandvekar 2013-10-08 00:14:49 EDT
Merged in v0.7-rc2 upstream ... closing!

Note You need to log in before you can comment on or make changes to this bug.