Bug 1015877 - internationalized domain aliases
internationalized domain aliases
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: UpcomingRelease
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 09:10 EDT by nardus
Modified: 2015-05-14 20:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 23:38:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nardus 2013-10-06 09:10:35 EDT
Description of problem:
I'm unable to add internationalized domain aliases (as in domain names containing accents or other characters outside ASCII). Applicable example: www.pasabaporaquí.com or www.pasabaporaquí.es, both valid domains, not accepted 

Version-Release number of selected component (if applicable):


How reproducible:
Always.


Steps to Reproduce:
1.rhc alias add netpress www.pasabaporaquí.es


Actual results:
Alias added.

Expected results:
"The specified alias is not allowed: 'www.pasabaporaquí.es'"

Additional info:
Same result using the web interface.
Comment 1 nardus 2013-10-07 13:47:42 EDT
Internationalized domains may be added in punycode, so I guess it's not a bug, but it should be made explicit somewhere.

E.g.: www.xn--pasabaporaqu-3fb.com
Comment 2 Rajat Chopra 2013-10-08 23:38:56 EDT
Feature request added in Trello - 
https://trello.com/c/hLxZjYwP/139-internationalised-scope-for-domain-names

Note You need to log in before you can comment on or make changes to this bug.