Bug 1015886 - seahorse-nautilus plugin does not encrypt/decrypt any file
seahorse-nautilus plugin does not encrypt/decrypt any file
Status: CLOSED DUPLICATE of bug 1007238
Product: Fedora
Classification: Fedora
Component: seahorse-nautilus (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Rui Matos
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 10:11 EDT by Paolo Leoni
Modified: 2013-10-10 12:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 12:57:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paolo Leoni 2013-10-06 10:11:39 EDT
Description of problem:
seahorse-nautilus should adding a context manu in nautilus in order to decrypt/encrypt gpg files.

Actually, only "Encrypt/sing" option is shown but that option doesn't work (it show dialog with recipients and password request) but no encrypted file is created.

And, second issue, if I select an encrypted file, no "Decrypt" option is shown.

Version-Release number of selected component (if applicable):
seahorse-nautilus.x86_64      3.8.0-1.fc19   

How reproducible:


Steps to Reproduce:
1. yum -y install seahorse-nautilus
2. righ click on a file
3. click on "Encrypt"

Actual results:
No encrypted file is created.
No "Decrypt" option is show while I'm selecting a gpg file.

Expected results:
File selected is correctly encrypted/decrypted.

Additional info:
Comment 1 Stef Walter 2013-10-07 05:16:08 EDT
Could you run seahorse-tool from the command line to see why things aren't working?

$ seahorse-tool --encrypt /path/to/my-file.ext

Once you do, could you post the output here? Thanks.
Comment 2 Paolo Leoni 2013-10-07 18:08:57 EDT
Hi Stef, this is the output (after command I selected my gpg public key in the dialog):


** (seahorse-tool:13788): WARNING **: couldn't load all the keys (1/2) from GPGME

(seahorse-tool:13788): GLib-WARNING **: GChildWatchSource: Exit status of a child process was requested but ECHILD was received by waitpid(). Most likely the process is ignoring SIGCHLD, or some other thread is invoking waitpid() with a nonpositive first argument; either behavior can break applications that use g_child_watch_add()/g_spawn_sync() either directly or indirectly.



Thank you.
Comment 3 Stef Walter 2013-10-10 12:57:47 EDT

*** This bug has been marked as a duplicate of bug 1007238 ***

Note You need to log in before you can comment on or make changes to this bug.