Bug 1015899 - [abrt] yum-utils-1.1.31-17.fc20: config.py:1187:_getsysver:YumBaseError: Error: rpmdb open failed
[abrt] yum-utils-1.1.31-17.fc20: config.py:1187:_getsysver:YumBaseError: Erro...
Status: CLOSED DUPLICATE of bug 982043
Product: Fedora
Classification: Fedora
Component: mock (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Clark Williams
Fedora Extras Quality Assurance
abrt_hash:86506b4195ebca86a90a629882e...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 11:42 EDT by D. Charles Pyle
Modified: 2013-10-07 05:20 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-07 05:20:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.00 KB, text/plain)
2013-10-06 11:42 EDT, D. Charles Pyle
no flags Details
File: environ (153 bytes, text/plain)
2013-10-06 11:42 EDT, D. Charles Pyle
no flags Details

  None (edit)
Description D. Charles Pyle 2013-10-06 11:42:11 EDT
Description of problem:
The error seems to occur when trying to build packages using mock.  Not sure how or why but it occurs after a failure to build.

Accompanying error that always occurs since Fedora 19:

Start: Outputting list of installed packages
ERROR: Exception(/home/dcpyle/rpmbuild/SRPMS/directfb-1.6.2-3.fc19.src.rpm) Config(fedora-20-i386) 1 minutes 7 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-20-i386/result
ERROR: Command failed. See logs for output.
 # /usr/bin/repoquery -c /tmp/tmp3NRSAf --installed -a --qf '%{nevra} %{buildtime} %{size} %{pkgid} %{yumdb_info.from_repo}' > /var/lib/mock/fedora-20-i386/result/installed_pkgs

Version-Release number of selected component:
yum-utils-1.1.31-17.fc20

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python -tt /usr/bin/repoquery -c /tmp/tmpKx1sne --installed -a --qf '%{nevra} %{buildtime} %{size} %{pkgid} %{yumdb_info.from_repo}'
dso_list:       yum-3.4.3-106.fc20.noarch
executable:     /usr/bin/repoquery
kernel:         3.11.3-301.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
config.py:1187:_getsysver:YumBaseError: Error: rpmdb open failed

Traceback (most recent call last):
  File "/usr/bin/repoquery", line 1543, in <module>
    main(sys.argv)
  File "/usr/bin/repoquery", line 1413, in main
    repoq.conf
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1054, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 344, in _getConfig
    startupconf = config.readStartupConfig(fn, root, releasever)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1036, in readStartupConfig
    startupconf.distroverpkg)
  File "/usr/lib/python2.7/site-packages/yum/config.py", line 1187, in _getsysver
    raise Errors.YumBaseError("Error: " + str(e))
YumBaseError: Error: rpmdb open failed

Local variables in innermost frame:
installroot: '/var/lib/mock/fedora-20-i386/root/'
e: error('rpmdb open failed',)
ts: <rpmUtils.transaction.TransactionWrapper instance at 0x14b0878>
distroverpkg: 'redhat-release'

Potential duplicate: bug 996027
Comment 1 D. Charles Pyle 2013-10-06 11:42:15 EDT
Created attachment 808579 [details]
File: backtrace
Comment 2 D. Charles Pyle 2013-10-06 11:42:18 EDT
Created attachment 808580 [details]
File: environ
Comment 3 Zdeněk Pavlas 2013-10-07 05:20:27 EDT
This seems to be a bug in mockbuild.  It runs the package_state plugin without a properly initialized installroot, and this results in repoquery exception.

https://bugzilla.redhat.com/show_bug.cgi?id=982043#c21

*** This bug has been marked as a duplicate of bug 982043 ***

Note You need to log in before you can comment on or make changes to this bug.