Bug 10159 - rpm dumps core when trying to remove corrupted entry
rpm dumps core when trying to remove corrupted entry
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-13 18:58 EST by Adam Thompson
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-13 18:58:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Johnson 2000-06-23 11:18:50 EDT
rpm expects consistent data from the database. If the data is inconsistent
(i.e. you haven't done a --rebuilddb), all sorts of weird problems, including
seg faults, occur. Do a --rebuildb, and retry the operation. If you still
have a problem, tar up a copy of /var/lib/rpm and mail it to <jbj@redhat.com>
so I can figger what the problem is. Please include the version/release of
rpm that you used.

Note You need to log in before you can comment on or make changes to this bug.