Bug 1015906 - updating nspr.i686 0:3.15.1-3.fc19 fails because of dependency problems
updating nspr.i686 0:3.15.1-3.fc19 fails because of dependency problems
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nss (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Elio Maldonado Batiz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-06 12:53 EDT by Joachim Backes
Modified: 2013-10-14 13:11 EDT (History)
6 users (show)

See Also:
Fixed In Version: nss-util-3.15.2-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-09 20:59:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-10-06 12:53:34 EDT
Description of problem:
Updating nss.i686 0:3.15.1-3.fc19 by yum fails (dependency!):

Loaded plugins: langpacks, refresh-packagekit
Warning: Environment Group cinnamon-desktop-environment does not exist.
Resolving Dependencies
--> Running transaction check
---> Package nss.i686 0:3.15.1-3.fc19 will be updated
---> Package nss.x86_64 0:3.15.1-3.fc19 will be updated
---> Package nss.i686 0:3.15.2-1.fc19 will be an update
--> Processing Dependency: nss-util >= 3.15.2 for package: nss-3.15.2-1.fc19.i686
--> Processing Dependency: nss-softokn(x86-32) >= 3.15.2 for package: nss-3.15.2-1.fc19.i686
---> Package nss.x86_64 0:3.15.2-1.fc19 will be an update
--> Processing Dependency: nss-util >= 3.15.2 for package: nss-3.15.2-1.fc19.x86_64
--> Processing Dependency: nss-softokn(x86-64) >= 3.15.2 for package: nss-3.15.2-1.fc19.x86_64
---> Package nss-sysinit.x86_64 0:3.15.1-3.fc19 will be updated
---> Package nss-sysinit.x86_64 0:3.15.2-1.fc19 will be an update
---> Package nss-tools.x86_64 0:3.15.1-3.fc19 will be updated
---> Package nss-tools.x86_64 0:3.15.2-1.fc19 will be an update
--> Finished Dependency Resolution
Error: Package: nss-3.15.2-1.fc19.i686 (updates-testing)
           Requires: nss-util >= 3.15.2
           Installed: nss-util-3.15.1-1.fc19.i686 (@updates-testing)
               nss-util = 3.15.1-1.fc19
           Available: nss-util-3.14.3-1.fc19.i686 (fedora)
               nss-util = 3.14.3-1.fc19
Error: Package: nss-3.15.2-1.fc19.i686 (updates-testing)
           Requires: nss-softokn(x86-32) >= 3.15.2
           Installed: nss-softokn-3.15.1-1.fc19.i686 (@updates-testing)
               nss-softokn(x86-32) = 3.15.1-1.fc19
           Available: nss-softokn-3.14.3-1.fc19.i686 (fedora)
               nss-softokn(x86-32) = 3.14.3-1.fc19
Error: Package: nss-3.15.2-1.fc19.x86_64 (updates-testing)
           Requires: nss-util >= 3.15.2
           Installed: nss-util-3.15.1-1.fc19.i686 (@updates-testing)
               nss-util = 3.15.1-1.fc19
           Available: nss-util-3.14.3-1.fc19.i686 (fedora)
               nss-util = 3.14.3-1.fc19
Error: Package: nss-3.15.2-1.fc19.x86_64 (updates-testing)
           Requires: nss-softokn(x86-64) >= 3.15.2
           Installed: nss-softokn-3.15.1-1.fc19.x86_64 (@updates-testing)
               nss-softokn(x86-64) = 3.15.1-1.fc19
           Available: nss-softokn-3.14.3-1.fc19.x86_64 (fedora)
               nss-softokn(x86-64) = 3.14.3-1.fc19
 You could try using --skip-broken to work around the problem


Version-Release number of selected component (if applicable):
nss-3.15.1-3.fc19.x86_64
nss-3.15.1-3.fc19.i686


How reproducible:
always

Steps to Reproduce:
1.yum update --enablerepo=updates-testing 
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Elio Maldonado Batiz 2013-10-06 13:40:05 EDT
Looking at 
https://admin.fedoraproject.org/updates/FEDORA-2013-18382/nspr-4.10.1-1.fc19,nss-3.15.2-1.fc19 
shows me that the nss-softokn-3.15.2-1.fc19 and nss-util-3.15.2-1.fc19 packages, which are part of the nss update bundle, are missing. I had included them when I created and pushed the bodhi update and they got dropped for some reason. I'll pushed
Comment 2 Elio Maldonado Batiz 2013-10-06 13:58:53 EDT
I think I know the reason, and its looks like my fault. I expired the nss-softokn and nss-util from the buildroot override prematurely. I have unexpired them and give a two day duration. It will take a while before they show up so I can add them to the bodhi update. My apologies and thanks in advance for your patience.
Comment 3 Fedora Update System 2013-10-06 14:08:26 EDT
nss-3.15.1-5.fc19, nss-util-3.15.2-1.fc19, nss-softokn-3.15.2-1.fc19, nspr-4.10.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-18382/nss-3.15.1-5.fc19,nss-util-3.15.2-1.fc19,nss-softokn-3.15.2-1.fc19,nspr-4.10.1-1.fc19
Comment 4 Fedora Update System 2013-10-06 14:10:03 EDT
nss-util-3.15.2-1.fc18, nspr-4.10.1-1.fc18, nss-3.15.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2013-18392/nss-util-3.15.2-1.fc18,nss-3.15.2-1.fc18,nspr-4.10.1-1.fc18
Comment 5 Joachim Backes 2013-10-07 02:34:11 EDT
(In reply to Fedora Update System from comment #3)
> nss-3.15.1-5.fc19, nss-util-3.15.2-1.fc19, nss-softokn-3.15.2-1.fc19,
> nspr-4.10.1-1.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/FEDORA-2013-18382/nss-3.15.1-5.fc19,
> nss-util-3.15.2-1.fc19,nss-softokn-3.15.2-1.fc19,nspr-4.10.1-1.fc19


Works for me, thanks.
Comment 6 Ali Akcaagac 2013-10-07 07:29:25 EDT
This is also valid for your F18 commit.

Please be aware, that you broke the update process of a stable system for a couple of days now.

A side note!

I had plenty of issues with nss-* dependencies within' F18 in the recent past, due to missing or broken set of nss-* packages. That's no one timer!

;--- f18 ---
Error: Package: nss-3.15.2-1.fc18.i686 (updates-testing)
           Requires: nss-softokn(x86-32) >= 3.15.2
           Available: nss-softokn-3.14-5.fc18.i686 (fedora)
               nss-softokn(x86-32) = 3.14-5.fc18
           Installing: nss-softokn-3.15.1-1.fc18.i686 (updates)
               nss-softokn(x86-32) = 3.15.1-1.fc18
Error: Package: nss-3.15.2-1.fc18.i686 (updates-testing)
           Requires: nss-util >= 3.15.2
           Available: nss-util-3.14-1.fc18.i686 (fedora)
               nss-util = 3.14-1.fc18
           Installing: nss-util-3.15.1-1.fc18.i686 (updates)
               nss-util = 3.15.1-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
;-----------

;--- f19 ---
Error: Package: nss-3.15.2-1.fc18.i686 (updates-testing)
           Requires: nss-softokn(x86-32) >= 3.15.2
           Available: nss-softokn-3.14-5.fc18.i686 (fedora)
               nss-softokn(x86-32) = 3.14-5.fc18
           Installing: nss-softokn-3.15.1-1.fc18.i686 (updates)
               nss-softokn(x86-32) = 3.15.1-1.fc18
Error: Package: nss-3.15.2-1.fc18.i686 (updates-testing)
           Requires: nss-util >= 3.15.2
           Available: nss-util-3.14-1.fc18.i686 (fedora)
               nss-util = 3.14-1.fc18
           Installing: nss-util-3.15.1-1.fc18.i686 (updates)
               nss-util = 3.15.1-1.fc18
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
;-----------
Comment 7 Ali Akcaagac 2013-10-07 07:30:56 EDT
%s/fc18/fc19/g

For the f19 copy&paste. You got the point.
Comment 8 Dan Mashal 2013-10-07 23:26:31 EDT
nspr fc19 br override expired causing fc19 buildroot to break. I extended the br override for you to fix the buildroot.
Comment 9 Fedora Update System 2013-10-08 07:31:24 EDT
Package nss-3.15.1-5.fc19, nss-util-3.15.2-1.fc19, nss-softokn-3.15.2-1.fc19, nspr-4.10.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nss-3.15.1-5.fc19 nss-util-3.15.2-1.fc19 nss-softokn-3.15.2-1.fc19 nspr-4.10.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18382/nss-3.15.1-5.fc19,nss-util-3.15.2-1.fc19,nss-softokn-3.15.2-1.fc19,nspr-4.10.1-1.fc19
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2013-10-09 20:59:25 EDT
nss-util-3.15.2-1.fc19, nss-softokn-3.15.2-1.fc19, nspr-4.10.1-1.fc19, nss-3.15.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2013-10-14 03:13:47 EDT
nss-util-3.15.2-1.fc18, nss-softokn-3.15.2-1.fc18, nspr-4.10.1-1.fc18, nss-3.15.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2013-10-14 13:11:45 EDT
nss-util-3.15.2-1.fc18, nss-softokn-3.15.2-1.fc18, nspr-4.10.1-1.fc18, nss-3.15.2-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.