This service will be undergoing maintenance at 03:30 UTC, 2016-05-27. It is expected to last about 2 hours
Bug 1015976 - tests failing on big endians
tests failing on big endians
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: knot (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Včelák
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ZedoraTracker
  Show dependency treegraph
 
Reported: 2013-10-07 03:55 EDT by Dan Horák
Modified: 2013-11-10 01:15 EST (History)
2 users (show)

See Also:
Fixed In Version: knot-1.3.2-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-18 15:42:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan Horák 2013-10-07 03:55:29 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Dan Horák 2013-10-07 03:57:48 EDT
Starting with version 1.3 there are tests that fail on big endian platforms like ppc or s390 on both 32 and 64 bits

...
ok 345 - rrset: rdata_item_size
ok 346 - rrset: merge
ok 347 - rrset: merge no dupl
ok 348 - rrset: next dname
ok 349 - rrset: remove rr
ok 350 - rrset: find pos
# Testing unit: Wire
#   Failed test '16-bit write'
#   at libknot/wire_tests.c line 60.
#   Failed test '32-bit write'
#   at libknot/wire_tests.c line 76.
#   Failed test '48-bit read'
#   at libknot/wire_tests.c line 84.
#   Failed test '48-bit write'
#   at libknot/wire_tests.c line 93.
# Testing unit: dname
# Testing unit: zone tree
# Testing unit: libknot/sign
# Testing unit: libknot/rrset
# Looks like you failed 4 tests of 350 run.
FAIL: unittests


Version-Release number of selected component (if applicable):
knot-1.3.2-1.fc20
Comment 3 Jan Včelák 2013-10-07 04:24:27 EDT
Thank you for the report.

I do not have access to big endian hardware. Dan, please, can you point me how to submit scratch builds to s390/ppc koji? Do I need some additional permissions?

Jan
Comment 4 Dan Horák 2013-10-07 04:28:28 EDT
(In reply to Jan Včelák from comment #3)
> Thank you for the report.
> 
> I do not have access to big endian hardware. Dan, please, can you point me
> how to submit scratch builds to s390/ppc koji? Do I need some additional
> permissions?

the procedure is same as with scratch builds on primary, just use $(arch)-koji, where arch is s390 or ppc, for example "s390-koji build --scratch f20 knot-1.3-fixed.src.rpm"
Comment 5 Jan Včelák 2013-10-07 04:37:28 EDT
(In reply to Dan Horák from comment #4)
> the procedure is same as with scratch builds on primary, just use
> $(arch)-koji, where arch is s390 or ppc, for example "s390-koji build
> --scratch f20 knot-1.3-fixed.src.rpm"

Perfect, thanks! I will take a look at it soon.
Comment 6 Jan Včelák 2013-10-08 09:21:39 EDT
The problem was in unit tests, not in the wire format writing/reading code. Anyway, the test was completely rewritten because it was unnecessarily complicated.

Resolved in:
knot-1.3.2-2.fc19
knot-1.3.2-2.fc20
knot-1.3.2-2.fc21
Comment 7 Fedora Update System 2013-10-08 09:31:00 EDT
knot-1.3.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-18086/knot-1.3.2-2.fc19
Comment 8 Fedora Update System 2013-10-08 09:31:35 EDT
knot-1.3.2-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/knot-1.3.2-2.fc20
Comment 10 Dan Horák 2013-10-08 13:06:04 EDT
(In reply to Jan Včelák from comment #9)
> I have submitted the builds into ppc and s390 as well. The build succeeds,
> but tagging od f20 build failed.
> 
> http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=200899 (f19 ppc)
> http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=200897 (f20 ppc)
> http://ppc.koji.fedoraproject.org/koji/buildinfo?buildID=200898 (f21 ppc)
> 
> https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1227651 (f19 s390)
> https://s390.koji.fedoraproject.org/koji/taskinfo?taskID=1227653 (f20 s390)

Thanks for the fast fix, Jan. There is no need to do builds on ppc or s390 (generally secondary arches), they are started automagically after a build finishes and is tagged in primary koji.
Comment 11 Jan Včelák 2013-10-08 13:50:00 EDT
(In reply to Dan Horák from comment #10)
> Thanks for the fast fix, Jan. There is no need to do builds on ppc or s390
> (generally secondary arches), they are started automagically after a build
> finishes and is tagged in primary koji.

No problem. OK, I will keep it in mind for the next time.
Comment 12 Fedora Update System 2013-10-09 10:28:57 EDT
Package knot-1.3.2-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing knot-1.3.2-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18547/knot-1.3.2-2.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2013-10-18 15:42:17 EDT
knot-1.3.2-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-11-10 01:15:54 EST
knot-1.3.2-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.