Bug 1015995 - packstack shouldn't set api_paste_config for nova
packstack shouldn't set api_paste_config for nova
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
high Severity high
: rc
: 4.0
Assigned To: Martin Magr
Lon Hohberger
: OtherQA, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 04:58 EDT by Xavier Queralt
Modified: 2016-04-26 16:03 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.14.dev919.el6ost
Doc Type: Bug Fix
Doc Text:
The authtoken configuration values filter:authtoken/auth_* have been moved to /etc/nova/nova.conf as keystone_authtoken/auth_* values.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:26:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 50915 None None None Never
OpenStack gerrit 54306 None None None Never
OpenStack gerrit 55545 None None None Never
OpenStack gerrit 59956 None None None Never

  None (edit)
Description Xavier Queralt 2013-10-07 04:58:27 EDT
Description of problem:

In RHOS 4.0 and RDO havana we will move the api-paste.ini from /etc/nova/ to /usr/share/nova. We do this because users don't need to modify its contents and will allow us to update the file without having to preoccupy about local changes.

The new location will be set from the package provided nova-dist.conf under the key api_paste_config, but right now packstack already sets this key in the nova configuration file pointing to /etc/nova/api-paste.ini.

Could we update the nova puppet module to not add this key in the configuration file? This is the location in nova puppet module where this key is set:

https://github.com/stackforge/puppet-nova/blob/master/manifests/api.pp#L71

Note that we'll have the same problem with cinder but I see that packstack modifies its api-paste.ini. I don't know how we should proceed with that.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Martin Magr 2013-10-07 09:55:40 EDT
Since using nova_paste_api_ini resource in the puppet class "nova::api" modifies api-paste.ini file we would also need to change https://github.com/stackforge/puppet-nova/blob/master/lib/puppet/provider/nova_paste_api_ini/ini_setting.rb#L19 ... so that would need to make it modifiable I guess.
Comment 3 Xavier Queralt 2013-10-07 10:32:00 EDT
I think that packstack shouldn't modify api-paste-dist.ini at all (becase it will be overiden by a new package).

Right now packstack will update the authtoken configuration under api-paste.ini. What if we moved those keys to nova.conf?
Comment 4 Martin Magr 2013-10-09 10:07:17 EDT
Packstack (or puppet-nova module) is not modifying api-paste-dist.ini at all.
Comment 5 Alvaro Lopez Ortega 2013-12-04 08:00:25 EST
Patch waiting for review: https://review.openstack.org/#/c/59956/
Comment 6 Scott Lewis 2013-12-09 10:33:41 EST
Adding OtherQA for bugs in MODIFIED
Comment 9 Lon Hohberger 2013-12-11 14:58:33 EST
This was present in api-paste.ini but not nova.conf after installation on my test run using openstack-packstack-2013.1.1-0.37.dev705.el6ost.noarch:

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory
admin_tenant_name=services
admin_user=nova
auth_port=35357
admin_password=276900cafc4243c3
auth_protocol=http
auth_host=192.168.122.189


The following is present in /etc/nova/nova.conf but were not present in api-paste.ini in the filter:authtoken section after an installation using openstack-packstack-2013.2.1-0.14.dev919.el6ost.noarch:

[keystone_authtoken]
admin_tenant_name=services
admin_user=nova
admin_password=2ac5dd71c73b4c8b
auth_host=192.168.122.97
auth_port=35357
auth_protocol=http
auth_uri=http://192.168.122.97:5000/
Comment 11 errata-xmlrpc 2013-12-19 19:26:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.