Bug 1015999 - [redhat-support-plugin-rhev] redhatsupportplugin.conf disappeared from /etc
[redhat-support-plugin-rhev] redhatsupportplugin.conf disappeared from /etc
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: redhat-support-plugin-rhev (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Spenser Shumaker
Jiri Belka
subeng
: Regression, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 05:09 EDT by Jiri Belka
Modified: 2014-01-21 11:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
redhatsupportplugin.conf disappeared from /etc. /usr is not usual place to edit config files, so put please back the conf. thank you!
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:58:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Belka 2013-10-07 05:09:19 EDT
Description of problem:

redhatsupportplugin.conf disappeared from /etc. /usr is not usual place to edit config files, so put please back the conf. thank you!

https://code.engineering.redhat.com/gerrit/gitweb?p=redhat-support-plugin-rhev.git;a=commit;h=604e582de7b66a168e211040842e2829b066245b

# rpm -qlcp redhat-support-plugin-rhev-3.3.0-8.el6ev.noarch.rpm 
/etc/httpd/conf.d/redhat-support-plugin-rhev-proxy.conf
/etc/ovirt-engine/engine.conf.d/50-redhat-support-plugin.conf
/etc/pam.d/ovirt-sosreport
/etc/security/console.apps/ovirt-sosreport
/usr/share/ovirt-engine/redhat-support-plugin-rhev-ear-3.3.0.ear/redhatsupportplugin.conf

diff --git a/redhat-support-plugin-rhev.spec.tmpl b/redhat-support-plugin-rhev.spec.tmpl

index c8148b3..c779777 100644 (file)


--- a/redhat-support-plugin-rhev.spec.tmpl
+++ b/redhat-support-plugin-rhev.spec.tmpl
@@ -89,7 +89,7 @@ popd
 
 # Copy these two files that are required for the plugin
 cp -r ui-plugins %{buildroot}/usr/share/ovirt-engine/ui-plugins
-install -m 644 redhatsupportplugin.conf %{buildroot}/etc/ovirt-engine/
+install -m 644 redhatsupportplugin.conf %{buildroot}/usr/share/ovirt-engine/redhat-support-plugin-rhev.ear/
 
 # Copy file to deploy ear file
 install -m 644 deploy/50-redhat-support-plugin.conf %{buildroot}/etc/ovirt-engine/engine.conf.d/
@@ -130,7 +130,7 @@ fi
 /usr/share/ovirt-engine/*
 %dir /usr/share/ovirt-engine/ui-plugins/redhat_support_plugin_rhev
 /usr/share/ovirt-engine/ui-plugins*
-%config(noreplace) /etc/ovirt-engine/redhatsupportplugin.conf
+%config(noreplace) /usr/share/ovirt-engine/redhat-support-plugin-rhev.ear/redhatsupportplugin.conf
 %defattr(-,root,root,-) 
 %config(noreplace) /etc/pam.d/ovirt-sosreport
 %config(noreplace) /etc/security/console.apps/ovirt-sosreport
@@ -144,7 +144,7 @@ fi
 
 %posttrans
 #Add version to config file 
-printf "\nversion=${name}-${version}-${release}" >> /etc/ovirt-engine/redhatsupportplugin.conf
+printf "\nversion=${name}-${version}-${release}" >> /usr/share/ovirt-engine/redhat-support-plugin-rhev.ear/redhatsupportplugin.conf
 
 # RHEV Support Plugin installed - tell JBoss that we want engine.ear redeployed to action it.
 if [ -d /var/lib/ovirt-engine/deployments ] ; then

Version-Release number of selected component (if applicable):
redhat-support-plugin-rhev-3.3.0-8.el6ev

How reproducible:
100%

Steps to Reproduce:
1. rpm -qlcp $package
2.
3.

Actual results:
config missing in /etc

Expected results:
config must be in /etc, so one does not need to guess how to edit the plugin configuration, especially if the rpm has *no* documentation.

Additional info:
fyi /usr is not really pleace to edit a conf file. historically /usr has could been either shared via network or been read-only. (yes, i'm pedant ;)
Comment 1 Spenser Shumaker 2013-10-11 11:28:09 EDT
In 3.3.0 we have started using rhev-setup to set some config values I was instructed by Alon to move all values that are not configured in "rhev-setup" from /etc/ovirt-engine/redhatsupportplugin.conf to /usr/share/ovirt-engine/redhat-support-plugin-rhev.ear/redhatsuppportplugin.conf.  The rhev-setup code is now responsible for the "/etc/ovirt-engine/redhatsupportplugin.conf" file.  Can this bug be closed as "working as designed"?
Comment 2 Jiri Belka 2013-10-15 03:38:53 EDT
I need to change URL to point to QA customer portal. So you want me to change a file in /usr? If it is not handling config file in /etc, why do you check it (according to source code)?
Comment 3 Spenser Shumaker 2013-10-15 08:02:10 EDT
The plugin checks both directories for config files.  The defaults and user changed values are located in "usr/share/.." and the values set during "rhevm-setup" are located in "etc/ovirt-engine/..".  These values are combined by the plugin with the "/usr/share/.." taking precedence.
Comment 6 Jiri Belka 2013-11-08 09:38:14 EST
Please clarify verification steps. There's 'isDevel' in the code but there's no discussion inside this BZ how it should work. Thank you.
Comment 7 Spenser Shumaker 2013-11-08 14:48:48 EST
Sorry Jiri,

Add the following lines to /etc/ovirt-engine/redhatsupportplugin.conf

URL=https://api.access.qa.redhat.com
isDevel=true


The url can be whatever staging server you would like.
Comment 8 Jiri Belka 2013-11-11 09:43:10 EST
ok, is22.
Comment 9 Charlie 2013-11-27 20:33:57 EST
This bug is currently attached to errata RHBA-2013:15513. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 10 Charlie 2013-12-05 19:52:29 EST
Does this need doc text? If so was there an actual problem or was it working as designed?

Thanks.
Comment 11 Spenser Shumaker 2013-12-09 10:24:10 EST
This should not need doc text.
Comment 12 errata-xmlrpc 2014-01-21 11:58:49 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0082.html

Note You need to log in before you can comment on or make changes to this bug.