Bug 1016011 - Binding properties (Binding Details, Interceptors, etc.) are not updated
Binding properties (Binding Details, Interceptors, etc.) are not updated
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: SwitchYard Editor (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER7
: 6.0.0
Assigned To: Brian Fitzpatrick
Tomas Rohovsky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 05:55 EDT by Tomas Rohovsky
Modified: 2016-01-04 00:58 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1758 Major Closed Binding properties (Binding Details, Interceptors, etc.) are not updated 2014-06-16 19:50:57 EDT

  None (edit)
Description Tomas Rohovsky 2013-10-07 05:55:59 EDT
Description of problem:
If I edit binding properties (Binding Details, Interceptors, Message Composer, etc.) and save the changes then the same binding properties (Binding Details, Interceptors, Message Composer, etc.) will be displayed after clicking on some other composite service/reference. That applies for all types of binding (SOAP, JMS, etc.).

Version-Release number of selected component (if applicable):
1.1.0.v20130912-2244-H393-M2

Steps to Reproduce:
1. click on some composite service/reference
2. edit binding properties
3. save the changes
4. immediately click on some other composite service/reference


Actual results:
The binding properties are same as the changed one.

Expected results:
The appropriate properties.

Additional info:
Comment 1 JBoss JIRA Server 2013-10-07 11:16:24 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1758

Tomas, I need more here step-wise. Do the bindings have to be the same? I've tried the same and different on multiple composite services and am not seeing this behavior. 

Can you attach a project and offer more specific steps to reproduce?
Comment 3 JBoss JIRA Server 2013-10-07 12:35:14 EDT
Tomas Rohovsky <trohovsk@redhat.com> made a comment on jira SWITCHYARD-1758

The bindings can be different. More detailed steps to reproduce:
1. click on some composite service/reference, show Bindings
2. edit binding properties - for example name
3. press tab
4. save the changes
5. click on some other composite service/reference
6. you should see the same name as you have saved in the previous binding
Comment 4 JBoss JIRA Server 2013-10-07 12:47:16 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1758

Turns out this is only an issue in the Properties view (not the Properties dialog) and occurs regardless of saving the changes. It's a refresh issue I'll see what I can do to get fixed. Thanks for the clarification Tomas!
Comment 5 JBoss JIRA Server 2013-10-07 15:17:17 EDT
Brian Fitzpatrick <bfitzpat@redhat.com> made a comment on jira SWITCHYARD-1758

Turned out that if the selected binding in the list was cached, it was selecting it regardless of whether it applied to the current contract (service/reference) being displayed. Added a check to make sure the previous binding actually belonged to the list of bindings before re-selecting it.
Comment 6 JBoss JIRA Server 2013-10-15 15:56:12 EDT
Rob Cernich <rcernich@redhat.com> made a comment on jira SWITCHYARD-1758

pushed
Comment 7 JBoss JIRA Server 2014-06-16 19:50:57 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1758 to Closed

Note You need to log in before you can comment on or make changes to this bug.