Bug 101605 - [NET] intel 82557/8/9 driver "e100" should be "eepro100"
[NET] intel 82557/8/9 driver "e100" should be "eepro100"
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Garzik
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-04 12:48 EDT by shrek-m
Modified: 2013-07-02 22:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-25 02:26:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
acpidmp.txt (48 bytes, text/plain)
2003-08-04 12:57 EDT, shrek-m
no flags Details
dmidecode.txt (4.29 KB, text/plain)
2003-08-04 12:59 EDT, shrek-m
no flags Details
lspci-vv.txt (5.43 KB, text/plain)
2003-08-04 12:59 EDT, shrek-m
no flags Details
The fix (796 bytes, text/plain)
2003-08-18 21:33 EDT, Wen-Hwa Tao
no flags Details

  None (edit)
Description shrek-m 2003-08-04 12:48:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Netscape/7.1

Description of problem:

kudzu:
local installation works.
the nic will be recognized while installation
all settings, ifconfig, ...  are ok
but the network is not reachable
tcpdump - nothing goes out only comes in

booting with
 acpi=off
 acpi=nopci
will not help.

on the chip i can read "S82557"

# kudzu -p
# vi /etc/sysconfig/hwconf
-
class: NETWORK
bus: PCI
detached: 0
device: eth0
driver: e100
desc: "Intel Corp.|82557/8/9 [Ethernet Pro 100]"
network.hwaddr: 00:A0:C9:1D:F7:89
vendorId: 8086
deviceId: 1229
subVendorId: 0000
subDeviceId: 0000
pciType: 1
-


the following fixed the problem.

# ifconfig eth0 down
# rmmod e100

# modprobe eepro100
# ifconfig eth0
# ping www.google.de
--> network is reachable
# modinfo eepro100
this output looks much better than    # modinfo e100


replace in /etc/modules.conf  e100 with eepro100

----
# alias eth0 e100
alias eth0 eepro100
----

# service network restart

Version-Release number of selected component (if applicable):
kudzu-1.1.13-1.1  kernel-2.4.21-20.1.2024.2.1.nptl

How reproducible:
Always

Steps to Reproduce:
1. install severn1, nic = intel "S82557" 1995
2. configure network while installation 
3. try to reach the network
4. check all setting, modules, firewall, ... :-(

Actual Results:  all seems to be ok
but the network is unreachable


Expected Results:  network should be reachable
after local installation and
while network-installation

Additional info:
anaconda:
net-inst via bootdisk fails because there is a link
but nothing seems to go out only come in (tcpdump)
choosing manually eepro100 -> but e100 will be loaded [alt][F3]
(with rhl 9 bootdisks network is reachable)
Comment 1 shrek-m 2003-08-04 12:57:38 EDT
Created attachment 93374 [details]
acpidmp.txt
Comment 2 shrek-m 2003-08-04 12:59:11 EDT
Created attachment 93375 [details]
dmidecode.txt
Comment 3 shrek-m 2003-08-04 12:59:48 EDT
Created attachment 93376 [details]
lspci-vv.txt
Comment 4 Bill Nottingham 2003-08-04 14:51:43 EDT
It's a bug in the e100 driver if it doesn't work
Comment 5 Michael K. Johnson 2003-08-08 15:26:43 EDT
Added Scott Feldman to the CC so that he can investigate the bug
Comment 6 Scott Feldman 2003-08-11 20:31:37 EDT
Fixed in driver version 2.3.18.  This new driver version has already been 
accepted into the tip-of-tree 2.6.x and 2.4.x kernels.  The change log from 
version 2.3.13 is:

o Bug fix: read skb->len after freeing skb [Andrew Morton] 
   akpm@zip.com.au
o Bug fix: 82557 (with National PHY) timeout during init 
   [Adam Kropelin] akropel1@rochester.rr.com
o Feature add: allow to change Wake On LAN when
   EEPROM disabled

The second change is the inportant one.

Also, while you're at it, the e1000 driver could stand to be updated to the 
latest version, 5.1.13.  This has also been accepted into the latest 2.4 and 
2.6 kernels.  The change log for e1000 is:

o Bug fix: request_irq() failure resulted in freeing resources 
  twice! [Don Fry (brazilnut@us.ibm.com)]
o Bug fix: fix VLAN support on ppc64 [Mark Rakes 
   (mrakes@vivato.net)]
o Bug fix: missing Tx cleanup opportunities during interrupt 
   handling.
o Bug fix: alloc_etherdev failure didn't cleanup regions in 
   probe.
o Cleanup: s/int/unsigned int/ for descriptor ring indexes.
Comment 7 Wen-Hwa Tao 2003-08-18 21:33:19 EDT
Created attachment 93737 [details]
The fix

Applying this to RHEL 3.0 B1 after the fix for #97908 should be fine.
Otherwise, manual application of patch may be needed.

Note You need to log in before you can comment on or make changes to this bug.