Bug 1016057 - there will be AVC denial in audit.log when jenkins build is finished
there will be AVC denial in audit.log when jenkins build is finished
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.5
Unspecified Linux
low Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 980353
  Show dependency treegraph
 
Reported: 2013-10-07 08:19 EDT by Brenton Leanhardt
Modified: 2013-10-30 08:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 980353
Environment:
Last Closed: 2013-10-30 05:52:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brenton Leanhardt 2013-10-07 08:19:04 EDT
+++ This bug was initially created as a clone of Bug #980353 +++

Description of problem:
In the end of jenkins build, it would generate avc denial in audit.log on node.

Version-Release number of selected component (if applicable):
http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-06-26.3/
selinux-policy-targeted-3.7.19-195.el6_4.10.noarch
selinux-policy-3.7.19-195.el6_4.10.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a php app and jenkins app, embed jenkins-client to php app

2. Make some changes in the php app git repo to trigger jenkins build

3. Monitoring the audit.log on the node, avc denial would be generated once the build action completed as "SUCCESS"
[root@node1 ~]# tailf /var/log/audit/audit.log |grep avc

type=AVC msg=audit(1372654405.272:100925): avc:  denied  { getattr } for  pid=29079 comm="java" path="/proc/mtrr" dev=proc ino=4026531957 scontext=unconfined_u:system_r:openshift_t:s0:c1,c382 tcontext=system_u:object_r:mtrr_device_t:s0 tclass=file

Actual results:

Expected results:
No such message in the log

Additional info:

--- Additional comment from RHEL Product and Program Management on 2013-07-02 03:17:30 EDT ---

Since this issue was entered in bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

--- Additional comment from Brenton Leanhardt on 2013-09-11 11:53:09 EDT ---

Miroslav,

Would it be possible to allow processes running in Gears to read MTRR info?

require {
        type mtrr_device_t;
        type openshift_t;
        class file getattr;
}

#============= openshift_t ==============
allow openshift_t mtrr_device_t:file getattr;

This is fairly low severity for now so it could wait until RHEL 6.5.

--- Additional comment from Miroslav Grepl on 2013-09-30 08:51:41 EDT ---

Are you getting more AVC msgs in permissive mode?

--- Additional comment from Brenton Leanhardt on 2013-09-30 14:37:20 EDT ---

There are no additional AVC messages in permissive mode.

--- Additional comment from Miroslav Grepl on 2013-10-07 08:04:43 EDT ---

Could you open a new rhel6.5 bug?
Comment 2 Miroslav Grepl 2013-10-08 04:30:08 EDT
If you add

require {
        type mtrr_device_t;
        type openshift_t;
        class file getattr;
}

#============= openshift_t ==============
dontaudit openshift_t mtrr_device_t:file getattr;


does it work?
Comment 3 Gaoyun Pei 2013-10-08 05:53:29 EDT
Tried to add 

require {
        type mtrr_device_t;
        type openshift_t;
        class file getattr;
}

#============= openshift_t ==============
allow openshift_t mtrr_device_t:file getattr;

It works during the jenkins build

and 

require {
        type mtrr_device_t;
        type openshift_t;
        class file getattr;
}

#============= openshift_t ==============
dontaudit openshift_t mtrr_device_t:file getattr;

also works, it wouldn't generate any AVC denial during the operation.
Comment 4 Daniel Walsh 2013-10-09 10:27:15 EDT
Probably should just add a dontaudit.
Comment 5 Miroslav Grepl 2013-10-30 05:52:31 EDT
More fixes have been added during RHEL6.5 cycle related to openshift and this bug should be fixed. If no, please re-open the bug and it will be addressed in RHEL6.6.

Note You need to log in before you can comment on or make changes to this bug.