This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 101607 - Error Message is "vague"
Error Message is "vague"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-04 13:16 EDT by Paul Campbell
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 20:12:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul Campbell 2003-08-04 13:16:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030516
Mozilla Firebird/0.6

Description of problem:
Error message "user database can not be read" doesn't give
useful information. The problem turned out to be a mismatch
between  passwd and shadow. Perhaps, the message could reflect
that. I ended up searching thru google and redhat for that
message. Since I got a hit on redhat, I wasn't the first to
wonder down that path.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.delete or add a line from either passwd or shadow
2.
3.
    

Expected Results:  Mismatch on number of entries for shadow and passwd. Correct
and restart.

Additional info:
Comment 1 Brent Fox 2003-08-14 20:12:01 EDT
I have changed the text to read:

"The user database cannot be read.  This problem is most likely caused by a
mismatch in /etc/passwd and /etc/shadow.  The program will exit now."

I hope that helps clarify the problem.  Should be fixed in
redhat-config-users-1.1.16-1.

Note You need to log in before you can comment on or make changes to this bug.