Bug 1016080 - [Doc Bug Fix] [Topic-4759] Document connectors parametrization more deeply
[Doc Bug Fix] [Topic-4759] Document connectors parametrization more deeply
Status: CLOSED DUPLICATE of bug 1159099
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.3.0
Unspecified Unspecified
unspecified Severity high
: post-GA
: ---
Assigned To: Scott Mumford
Jan Stefl
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 09:03 EDT by Jan Stefl
Modified: 2015-08-04 07:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Build Name: 14874, Administration and Configuration Guide-6.2-1 Build Date: 02-10-2013 13:01:57 Topic ID: 4759-458836 [Latest]
Last Closed: 2015-08-04 07:45:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stefl 2013-10-07 09:03:03 EDT
Title: Configure the Web Subsystem

Describe the issue:
Just five connectors attributes id documented, but there is more attributes:

Suggestions for improvement:
Document all connectors propertiers (from JBOSS_HOME/docs/schema/jboss-as-web_1_4.xsd):

<xs:attributeGroup name="web-connector-attlist">
   <xs:attribute name="name" use="required" />  <!-- documented already -->
   <xs:attribute name="protocol" use="required" /> <!-- documented already -->
   <xs:attribute name="scheme" use="required" /> <!-- documented already -->
   <xs:attribute name="socket-binding" use="required" /> <!-- documented already -->
   <xs:attribute name="enable-lookups" default="false" type="xs:boolean" />
   <xs:attribute name="proxy-name" />
   <xs:attribute name="proxy-port" />
   <xs:attribute name="redirect-port" />
   <xs:attribute name="secure" default="false" type="xs:boolean" />
   <xs:attribute name="max-post-size" />
   <xs:attribute name="max-save-post-size" />
   <xs:attribute name="enabled" default="true" type="xs:boolean" /> <!-- documented already -->
   <xs:attribute name="executor" type="xs:string" />
   <xs:attribute name="max-connections" />
</xs:attributeGroup>


Additional information:
You can take advantantage of CLI console to get info properties, like:
/profile=full-ha/subsystem=web/connector=ajp:read-resource-description
/profile=full-ha/subsystem=web/connector=http:read-resource-description
etc.
Comment 3 Russell Dickenson 2015-07-20 19:50:40 EDT
@Scott,

The added content looks OK to me.
Comment 4 Scott Mumford 2015-07-21 00:06:04 EDT
Cheers Russell.

Moving to MODIFIED pending rebuild to stage.
Comment 6 Radim Hatlapatka 2015-08-04 07:45:22 EDT
This part was already checked as part of BZ#1159099 and found issues are also being corrected as part of that BZ, Thereby closing this one as duplicate.

*** This bug has been marked as a duplicate of bug 1159099 ***

Note You need to log in before you can comment on or make changes to this bug.