Bug 1016090 - Duplicated test case - JBWS3084TestCase.java
Duplicated test case - JBWS3084TestCase.java
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Web Services (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: DR2
: EAP 6.3.0
Assigned To: Rebecca Searls
Rostislav Svoboda
Russell Dickenson
:
Depends On: 1061340
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 09:18 EDT by Rostislav Svoboda
Modified: 2014-07-03 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An instance of a duplicate name used on two test cases has been resolved in this release of JBoss EAP 6. Test case JBWS3084TestCase was renamed to JBWS3084CxfTestCase.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-28 11:24:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rostislav Svoboda 2013-10-07 09:18:09 EDT
[rsvoboda@steve jbossws-cxf-4.2.1.Final]$ find . | grep org.jboss.test.ws.saaj.jbws3084.JBWS3084TestCase
./modules/testsuite/shared-tests/src/test/java/org/jboss/test/ws/saaj/jbws3084/JBWS3084TestCase.java
./modules/testsuite/cxf-tests/src/test/java/org/jboss/test/ws/saaj/jbws3084/JBWS3084TestCase.java

I think JBWS3084TestCase should be merged and placed just into one module.
Content of test and support classes is different.

Test from shared-tests module seems to be more complex.
Comment 1 Rebecca Searls 2013-11-05 16:25:27 EST
Investigating deeper into these 2 tests they are significantly different
in their setUp and tearDown requirements.  The test file in the shared-tests
directory does not define any setUp and tearDown functionality, however the file 
in directory cxf-tests does.  There is significant setUp and tearDown code in 
class JBossWSCXFTestSetup, which (cxf-tests) JBWS3084TestCase is returning from
method JBWS3084TestCase.suite().  Because of this it is not practical or desirable to combine these 2 files.  

I would recommend the solution for the dup file names is to rename file
modules/testsuite/cxf-tests/src/test/java/org/jboss/test/ws/saaj/jbws3084/JBWS3084TestCase.java to JBWS3084CxfTestCase.java
Comment 2 Rostislav Svoboda 2013-11-06 02:53:41 EST
Agree with renaming, please proceed.

We need unique testcase / test-report names because of Jenkins reporting.
Comment 3 Rebecca Searls 2013-11-06 09:04:42 EST
JBWS3084TestCase.java renamed to JBWS3084CxfTestCase.java
   svn Committed revision 18064.
Comment 4 Rostislav Svoboda 2013-11-08 02:42:30 EST
https://source.jboss.org/changelog/JBossWS?cs=18064
Comment 6 Kabir Khan 2014-04-04 10:53:23 EDT
Setting to ON_QA since upgrade should fix this
Comment 7 Petr Sakař 2014-04-08 06:39:53 EDT
Verified for EAP 6.3.0.ER1

Note You need to log in before you can comment on or make changes to this bug.