Bug 1016118 - async between masterVersion : can't connect to StoragePool
async between masterVersion : can't connect to StoragePool
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
3.3
Unspecified Unspecified
medium Severity high
: ---
: 3.3.3
Assigned To: Liron Aravot
Aharon Canan
storage
:
Depends On:
Blocks: 1044897
  Show dependency treegraph
 
Reported: 2013-10-07 10:37 EDT by Ohad Basan
Modified: 2016-02-10 12:05 EST (History)
8 users (show)

See Also:
Fixed In Version: ovirt-3.3.3-beta1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1044897 (view as bug list)
Environment:
Last Closed: 2014-02-14 04:57:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22016 None None None Never
oVirt gerrit 22431 None None None Never

  None (edit)
Description Ohad Basan 2013-10-07 10:37:50 EDT
Description of problem:

We had a power outage while using ovirt 3.3.
it seems like the masterVersion was repeatedly updated in the database and was not updated in the storage hence the engine is failing to connect to the master storage domain
Comment 6 Liron Aravot 2013-11-05 09:35:40 EST
currently the behaviour is that the current master can't be selected as new master, that's a legacy behaviour..the reason that this was done was to attempt to prevent reconstructs in case that we have one domain which is inaccessible imo.. we could look into possibly changing this behaviour.
Comment 7 Allon Mureinik 2013-11-06 13:48:24 EST
We should always try to reconstruct on any available domain, with the current master having the lowest priority.
Comment 8 Sandro Bonazzola 2013-11-28 10:34:16 EST
Re-targeting to 3.3.3 since the bug is not resolved in 3.3.2 beta and is not blocking 3.3.2 release tracker (bug #1027349)
Comment 10 Allon Mureinik 2013-12-12 10:51:24 EST
Patch should be backported to the ovirt-engine-3.3 branch, returning to POST.
Comment 11 Allon Mureinik 2013-12-22 07:18:44 EST
This is an oVirt bug, not a RHEVM bug - it should be on MODIFIED until 3.3.3 is released.
Comment 12 Sandro Bonazzola 2014-02-14 04:57:21 EST
Closing as 3.3.3 has been released.

Note You need to log in before you can comment on or make changes to this bug.