Bug 1016163 - id prints incorrectly groups for the session
Summary: id prints incorrectly groups for the session
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coreutils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Ondrej Vasik
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On: 816708
Blocks: 1056252 1115430
TreeView+ depends on / blocked
 
Reported: 2013-10-07 15:58 UTC by Ondrej Vasik
Modified: 2019-05-20 11:06 UTC (History)
8 users (show)

Fixed In Version: coreutils-8.4-35.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 816708
: 1115430 (view as bug list)
Environment:
Last Closed: 2014-10-14 06:34:11 UTC
Target Upstream Version:


Attachments (Terms of Use)
proposed patch (577 bytes, patch)
2014-06-25 12:33 UTC, Petr Stodulka
no flags Details | Diff
proposed upstream patch (3.51 KB, patch)
2014-06-26 01:49 UTC, Pádraig Brady
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 473493 0 None None None Never
Red Hat Product Errata RHBA-2014:1457 0 normal SHIPPED_LIVE coreutils bug fix and enhancement update 2014-10-14 01:10:58 UTC

Comment 1 Ondrej Vasik 2013-10-07 16:00:04 UTC
Summary:
groups and id -G was fixed by 816708
simple id still contains the wrong group

Steps to reproduce:
1. Edit some user in /etc/passwd and change his gid to e.g. 1502 from 502

Actual results:
$ id
uid=501(Reset) gid=502(Reset) groups=1502,490(mock),502(Reset) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023
Expected results:
$ id
uid=501(Reset) gid=502(Reset) groups=490(mock),502(Reset) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023

(id -G and groups commands report correct output since coreutils-8.4-22.el6)

Comment 6 Petr Stodulka 2014-06-25 12:33:20 UTC
Created attachment 912082 [details]
proposed patch

Attached patch which is based on upstream patch for commands 'groups' and 'id -G'. I wait for upstream feedback.

Comment 7 Pádraig Brady 2014-06-26 01:49:26 UTC
Created attachment 912313 [details]
proposed upstream patch

Can we make this bug public?

Comment 12 errata-xmlrpc 2014-10-14 06:34:11 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1457.html


Note You need to log in before you can comment on or make changes to this bug.