Bug 1016174 - Python-tag requires libboost_python 1.53 but fedora 20 has 1.54.
Python-tag requires libboost_python 1.53 but fedora 20 has 1.54.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: python-tag (Show other bugs)
20
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On: 991882
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 12:15 EDT by io
Modified: 2013-12-13 22:37 EST (History)
4 users (show)

See Also:
Fixed In Version: python-tag-2013.1-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-13 22:37:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description io 2013-10-07 12:15:05 EDT
Description of problem:
Python-tag on fedora 20 is requires libboost_python 1.53 however, fedora 20 has libboost_python 1.54, which fails the dependency request.
Please see below:

Error: Package: python-tag-2013.1-1.fc20.x86_64 (fedora)
           Requires: libboost_python.so.1.53.0()(64bit)
           Removing: boost-python-1.53.0-14.fc19.x86_64 (@updates/19)
               libboost_python.so.1.53.0()(64bit)
           Updated By: boost-python-1.54.0-5.fc20.x86_64 (fedora)
              ~libboost_python.so.1.54.0()(64bit)


Version-Release number of selected component (if applicable):
20

How reproducible:
Have Fedora 19 distro rawhide, never moved to final release.
Trying to upgrade to 20 alpha.


Steps to Reproduce:
1. yum --releasever=20 distro-sync

Actual results:
Failure to upgrade because of dependencies

Expected results:
Successful upgrade

Additional info:

[root@ioFedora ~]# cat /etc/redhat-release 
Fedora release 19 (Schrödinger’s Cat)

[root@ioFedora ~]# uname -a
Linux ioFedora 3.11.3-201.fc19.x86_64 #1 SMP Thu Oct 3 00:47:03 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 Rolf Fokkens 2013-10-20 14:44:17 EDT
I guess python-tag just needs te be rebuilt, that's what I just did. When doing a "yum install ./python-tag-2013.1-1.fc20.x86_64.rpm everything seems to update fine.
Comment 2 rvcsaba 2013-11-15 17:49:58 EST
Please rebuild python-tag package! (I use sonata mpd client.)
Comment 3 Ankur Sinha (FranciscoD) 2013-11-24 22:24:01 EST
+1. I'll see if I can request a proven packager to rebuild python-tag for us.
Comment 4 Ankur Sinha (FranciscoD) 2013-11-24 23:25:12 EST
I just bumped the spec and rebuilt it in mock for both F20 and rawhide. it builds without any issues. Not quite sure why it failed to build in the first place.
Comment 5 Michael Schwendt 2013-11-25 06:04:46 EST
It fails for both Rawhide and F20 in koji's mock, because it tries to
download "distribute" (a fork of "setuptools"):

[...]
+ python setup.py build
Downloading http://pypi.python.org/packages/source/d/distribute/distribute-0.6.19.tar.gz
Traceback (most recent call last):
[...]
urllib2.URLError: <urlopen error [Errno -2] Name or service not known>
Comment 6 Fedora Update System 2013-11-25 07:28:18 EST
python-tag-2013.1-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/python-tag-2013.1-4.fc20
Comment 7 Fedora Update System 2013-11-25 22:57:24 EST
Package python-tag-2013.1-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-tag-2013.1-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22084/python-tag-2013.1-4.fc20
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-12-13 22:37:21 EST
python-tag-2013.1-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.