Bug 1016177 - Syntax coloring problem in Python code
Syntax coloring problem in Python code
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: vim (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Karsten Hopp
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 12:21 EDT by Petr Šplíchal
Modified: 2016-05-31 21:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 840824
Environment:
Last Closed: 2016-04-11 10:59:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Whole bug.py (31.36 KB, image/png)
2016-04-11 10:53 EDT, Karsten Hopp
no flags Details
bug.py after 7 <ctrl-e> <ctrl-l> (25.62 KB, image/png)
2016-04-11 10:54 EDT, Karsten Hopp
no flags Details

  None (edit)
Description Petr Šplíchal 2013-10-07 12:21:04 EDT
The same issue is present in the latest RHEL7 vim:
vim-enhanced-7.4.027-2.el7.x86_64

+++ This bug was initially created as a clone of Bug #840824 +++

Description of problem:

When the python code provided below is scrolled up so that the
line 7 disappears, the rest of the code is colored as a string.

Version-Release number of selected component (if applicable):
vim-enhanced-7.2.411-1.8.el6.x86_64

Steps to Reproduce:

1. vim bug.py
2. 7<ctrl-e>
3. <ctrl-l>
  
Python code:
$ cat bug.py
class Class(object)

    def __init__(value):
        """
        Heading

        Accepts the following formats (case does not matter):

            one
            two
            three
        """

        # Some short comment
        for i range(100):
            print i
Comment 2 Petr Šplíchal 2013-10-19 03:43:51 EDT
Editing code is sometimes very hard when affected by this bug as
the coloring is basically inversed and the language keywords are
appearing as a string. Karsten, do you think this could be fixed
in the near future?
Comment 3 RHEL Product and Program Management 2014-03-22 02:37:00 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Karsten Hopp 2016-04-11 10:53 EDT
Created attachment 1146011 [details]
Whole bug.py
Comment 5 Karsten Hopp 2016-04-11 10:54 EDT
Created attachment 1146012 [details]
bug.py after 7 <ctrl-e>  <ctrl-l>
Comment 6 Karsten Hopp 2016-04-11 10:59:33 EDT
Cannot reproduce on a freshly installed RHEL-7.2 with
vim-enhanced-7.4.160-1.el7.x86_64
vim-minimal-7.4.160-1.el7.x86_64
vim-common-7.4.160-1.el7.x86_64

See attachements, they look ok to me.

Note You need to log in before you can comment on or make changes to this bug.