Bug 1016231 - cinder: snapshots stuck in deleting forever when delete is sent while storage is unavailable
cinder: snapshots stuck in deleting forever when delete is sent while storage...
Status: CLOSED DUPLICATE of bug 1057832
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
x86_64 Linux
unspecified Severity medium
: ---
: 5.0 (RHEL 7)
Assigned To: Eric Harney
Dafna Ron
Depends On:
  Show dependency treegraph
Reported: 2013-10-07 14:11 EDT by Dafna Ron
Modified: 2016-04-26 20:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-04-29 08:51:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
logs (14.49 MB, application/x-gzip)
2013-10-07 14:11 EDT, Dafna Ron
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1236506 None None None Never

  None (edit)
Description Dafna Ron 2013-10-07 14:11:07 EDT
Created attachment 808973 [details]

Description of problem:

we had an outage and after all servers were restarted I tried sending a delete snapshot command. 
since there was a problem in gluster created by the outage cinder still failed to mount the storage and was down. 
once problem in storage was fixed, the snapshots are still stuck in deleting status. 

Version-Release number of selected component (if applicable):

[root@cougar06 ~(keystone_admin)]# rpm -qa |grep cinder 

How reproducible:

Steps to Reproduce:
1. configure cinder to work with gluster
2. create a volume and a snapshot
3. shut down gluster 
4. send a delete snapshot command
5. restart gluster and mount

Actual results:

snapshots are stuck in deleting forever 

Expected results:

snapshots should be deleted once the storage is back or failed right away by scheduler.
Additional info:

[root@cougar06 ~(keystone_admin)]# cinder snapshot-list 
|                  ID                  |              Volume ID               |  Status  | Display Name | Size |
| 4a6597fc-d33c-49b0-88e4-3dc0a6e9855c | 1560fa00-752b-4d7b-a747-3ef9bf483692 | deleting |     None     |  1   |
| 4ac236e1-61f1-47dc-a0fa-d96162622121 | 1560fa00-752b-4d7b-a747-3ef9bf483692 | deleting |     None     |  1   |

Comment 1 Sean Cohen 2014-04-29 08:51:01 EDT
Should be addressed by the new delete-snapshot taskflow.

*** This bug has been marked as a duplicate of bug 1057832 ***

Note You need to log in before you can comment on or make changes to this bug.