Bug 1016243 - Tuples lost in a with clause item.
Tuples lost in a with clause item.
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ER3
: 6.0
Assigned To: Van Halbert
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 14:38 EDT by Van Halbert
Modified: 2014-07-09 01:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-10 16:00:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-2690 Blocker Closed Tuples lost in a with clause item. 2015-06-25 03:16:35 EDT

  None (edit)
Comment 1 JBoss JIRA Server 2013-10-07 14:51:03 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2690 to Resolved
Comment 2 JBoss JIRA Server 2013-10-07 14:51:03 EDT
Steven Hawkins <shawkins@redhat.com> made a comment on jira TEIID-2690

As I recall this change was intended as part of TEIID-2442, but was not included probably due to the lack of a reproducing unit test.

The correction is to simply reuse the BatchIterator instance (just as is done with all other code paths that use BatchIterators).
Comment 5 belong 2013-11-17 22:08:18 EST
Fixed before GA of major release - setting to requires_doc_text- accordingly
Comment 6 JBoss JIRA Server 2013-12-05 15:51:59 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-2690 to Closed
Comment 7 wgibson 2014-02-11 08:14:39 EST
Verified with unit test:  TestWithClauseProcessing.java

Note You need to log in before you can comment on or make changes to this bug.