Bug 1016299 - [RFE] allow engines to add menus to top banner area
[RFE] allow engines to add menus to top banner area
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Tom McKay
sthirugn@redhat.com
: FutureFeature
Depends On:
Blocks: sam13-tracker 1004472
  Show dependency treegraph
 
Reported: 2013-10-07 16:12 EDT by Tom McKay
Modified: 2013-10-31 11:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 11:18:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom McKay 2013-10-07 16:12:51 EDT
Some engines may wish to add menus to the top banner area of UI (where the user account menu is now in upper right).

The necessary changes are here:
https://github.com/Katello/katello/pull/3110

with an example usage here:
https://github.com/Katello/katello-redhat-access-engine/pull/7
Comment 1 Tom McKay 2013-10-08 17:13:38 EDT
Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 13e7cb7b51928e67638f1538cf16f5d832a63e06
      https://github.com/Katello/katello/commit/13e7cb7b51928e67638f1538cf16f5d832a63e06
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2013-10-07 (Mon, 07 Oct 2013)
Comment 4 sthirugn@redhat.com 2013-10-30 12:35:54 EDT
Verifie
Comment 5 sthirugn@redhat.com 2013-10-30 12:37:23 EDT
Verified. 
-> gss plugin in now showing in SAM UI.  
-> able to search the knowledge base from SAM UI now.

Version Tested:
* candlepin-0.8.26-1.el6sam.noarch
* candlepin-cert-consumer-cloud-qe-6.idm.lab.bos.redhat.com-1.0-1.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.26-1.el6sam.noarch
* candlepin-tomcat6-0.8.26-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-11.el6sat.noarch
* katello-cli-common-1.4.3-11.el6sat.noarch
* katello-common-1.4.3.23-1.el6sam_splice.noarch
* katello-configure-1.4.4-5.el6sam.noarch
* katello-glue-candlepin-1.4.3.23-1.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3.23-1.el6sam_splice.noarch
* katello-headpin-1.4.3.23-1.el6sam_splice.noarch
* katello-headpin-all-1.4.3.23-1.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* thumbslug-0.0.34-1.el6sam.noarch
* thumbslug-selinux-0.0.34-1.el6sam.noarch
Comment 7 errata-xmlrpc 2013-10-31 11:18:26 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1489.html

Note You need to log in before you can comment on or make changes to this bug.