Bug 1016308 - rcs "co" command is very slow
rcs "co" command is very slow
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rcs (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Honza Horak
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: 1036527
  Show dependency treegraph
 
Reported: 2013-10-07 16:49 EDT by Andrew J. Schorr
Modified: 2014-01-03 03:44 EST (History)
1 user (show)

See Also:
Fixed In Version: rcs-5.9.2-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1036527 (view as bug list)
Environment:
Last Closed: 2014-01-03 03:33:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrew J. Schorr 2013-10-07 16:49:19 EDT
Description of problem: There seems to be a performance regression in newer versions of RCS.  I built RCS 5.7 and 5.9.1 on a Fedora 19 x86_64 system.  Running on the same RCS data, I timed the new and old versions for
the command "co -p1.1 <filename>".  With 5.9.1 (and 5.9), it takes over 1 minute.
With 5.7, it takes less than one second.  This is on a file with 3585
revisions in the RCS history.

This performance regression is present in versions 5.8.1 and 5.8.2 as well.


Version-Release number of selected component (if applicable): rcs-5.9.0-1.fc19.x86_64


How reproducible: Run "co -p1.1 <filename>" on a file with many many revisions.


Steps to Reproduce:
1. time co -p1.1 <filename> for a file with many revisions.
2.
3.

Actual results: It should take less than 1 second.


Expected results: It takes more than a minute.


Additional info:
Comment 1 Andrew J. Schorr 2013-10-07 17:49:16 EDT
FYI, I opened an upstream bug here:

https://savannah.gnu.org/bugs/index.php?40200
Comment 2 Honza Horak 2013-11-04 11:06:39 EST
Thanks for cooperate with upstream. FTR, this seems to be the fix:
http://git.savannah.gnu.org/cgit/rcs.git/commit/?h=p&id=e91adb0

...but there can still be some performance difference between 5.7 and current code -- mostly due to architectural changes [1]

[1] https://savannah.gnu.org/bugs/index.php?40200
Comment 3 Fedora Update System 2013-11-29 09:32:39 EST
rcs-5.9.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rcs-5.9.2-1.fc20
Comment 4 Fedora Update System 2013-11-29 09:41:06 EST
rcs-5.9.2-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rcs-5.9.2-1.fc19
Comment 5 Fedora Update System 2013-11-29 11:04:59 EST
Package rcs-5.9.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rcs-5.9.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22406/rcs-5.9.2-1.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-01-03 03:33:31 EST
rcs-5.9.2-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2014-01-03 03:44:33 EST
rcs-5.9.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.