Bug 101633 - can't get network address via dhcp after a PXEboot of the kernel
can't get network address via dhcp after a PXEboot of the kernel
Status: CLOSED DUPLICATE of bug 101630
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2003-08-04 17:41 EDT by david d zuhn
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:57:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description david d zuhn 2003-08-04 17:41:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
I've configured a machine to do PXE based network installations.  I've done many
network installations on this configuration, so I'm sure I've got a fairly
normal network configuration on my existing server (DHCP, tftp, etc).

This machine is completely headless.  A serial port is used for console access.
 I have no VGA screen attached, nor a mouse.  A
keyboard is attached, but is not used at all during this process.

I have the following two boot lines in the pxelinux config file:

label install-rhel
  kernel /redhat/rhel/ia32/vmlinuz
  append ip=dhcp initrd=/redhat/rhel/ia32/initrd.img  console=ttyS0,115200 vnc

label install-severn
  kernel /redhat/severn/vmlinuz
  append ip=dhcp initrd=/redhat/severn/initrd.img  console=ttyS0,115200 vnc

When I install RHEL (Taroon beta), my networking setup works as I expect.

When I install Severn, the installer is repeatedly offered an IP
address, but apparently ignores the offer and eventually times out and
re-prompts me for my networking configuration.   If I manually enter the right
values, and then I enter my NFS server information, the 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot my system via PXE.  The kernel and initrd are from severn disc 1,

2. use the pxelinux config line for install-severn (see above).   

3. I'm prompted for language (English), install type (NFS), and then the
installer does a round of DHCP queries (from my DHCP server log,
I see the DHCPREQUESTs and the DHCPOFFERs, which all look correct).

4. I'm then prompted to enter my networking information, with an option to use
DHCP.  If I use DHCP, the same round of activity 
occurs.  This occurs as many times as I'm willing to attempt the
cycle (probably 6 or 7 cycles).   

5. If I enter the information manually, I'm then prompted for my NFS server &
pathname and then (after a pause), I get the following error message "That
directory could not be mounted from the server.".   No NFS errors messages
showed up in the logs on my server machine.


Actual Results:  I cannot do a complete network installation.

Expected Results:  I should be able to do an installation entirely via the
network.  I am able to do so using Taroon or Red Hat Linux 9, on this exact
hardware configuration.

Additional info:

This machine has an e100 card as the sole network device.
Comment 1 david d zuhn 2003-08-04 17:43:57 EDT

*** This bug has been marked as a duplicate of 101630 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:58 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.