Bug 1016333 - Print Preview and Printing Problem with Firefox in Red Hat 6
Print Preview and Printing Problem with Firefox in Red Hat 6
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox (Show other bugs)
6.6
Unspecified Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 20:24 EDT by Ron
Modified: 2017-12-06 05:54 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:54:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ron 2013-10-07 20:24:04 EDT
Description of problem:Firefox on Red Hat and Red Hat-like (e.g., CentOS) systems often has problems with Print Preview and printing multiple pages. The problem is seen for versions of Linux like Red Hat, but I have not heard complaints from users of Firefox on other operating systems. This problem is common for printing webpages with several photo images or several styles defined. The Firefox browser shows the webpage properly, but the Firefox Print Preview and printing functions malfunction. Typically the first page is properly shown and printed, but the second page is a mess and no other pages are previewed or printed. For example, the site www.panamintcity.com has several photos (early October 2013). Firefox on Red Hat 6 shows the webpage, but Print Preview or direct printing fails to properly handle any pages other than the first page. Printed pages match the Print Preview rather than the browser's standard view. 


Version-Release number of selected component (if applicable): All recent versions of Firefox; Red Hat or CentOS 6. 


How reproducible: Tested on several installations, and the problem is also seen by other people in forums. 


Steps to Reproduce:
1. Use Firefox on Red Hat or CentOS to view a webpage like www.panamintcity.com.
2. From the File menu choose Print Preview and observe the pages. 
3. Print from Firefox. 

Actual results: Only the first page previews or prints properly. The second page is a mess. No other pages print or preview. 


Expected results: The Print Preview and printing functions should display or print pages properly so the results are similar to what the browser shows in its standard view. 


Additional info: This problem persists after several upgrades of Firefox and Red Hat or CentOS Linux.
Comment 2 Tim Waugh 2013-10-09 08:34:35 EDT
Changing component from cups to firefox as Print Preview does not get as far as cups.
Comment 3 RHEL Product and Program Management 2013-10-14 21:35:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jan Kurik 2017-12-06 05:54:12 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.