Bug 1016343 - [Doc Bug Fix] Disable Subdeployment Class Loader Isolation Within a EAR
[Doc Bug Fix] Disable Subdeployment Class Loader Isolation Within a EAR
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: post-GA
: EAP 6.4.3
Assigned To: Russell Dickenson
Martin Simka
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 20:55 EDT by Bruce Wolfe
Modified: 2015-10-20 08:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Instance Name: Not Defined Build: CSProcessor Builder Version 1.7 Build Name: 8699, Development Guide-6-2 Build Date: 20-12-2012 13:59:28
Last Closed: 2015-10-20 08:58:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bruce Wolfe 2013-10-07 20:55:20 EDT
Description of problem:
This section describes how to disable class loader isolation, but in the previous two sections (3.6.1 & 3.6.2) the documents indicate that it IS disabled by default and that you can enable isolation if needed. So, if I am reading this correctly then I am not sure if this section is needed; seems confusing to me or am I misreading it?

Perhaps there should be a corresponding ENABLE section as well? There is an alluded to enablement mentioned in section 3.6.1 (Class-Path in the MANIFEST.MF file), but no example.


Version-Release number of selected component (if applicable): 6.0.x


Additional info:
Comment 6 dereed 2015-07-21 20:15:29 EDT
The last sentence of 3.7.3 needs reversed.
- "disabled->enabled"
- "will have automatic dependencies" -> "will not have automatic dependencies".

3.7.1. needs some work.
- "These modules have the same behavior as any other module, with implicit dependencies on the parent module." would be better stated with something like "... as well as implicit ..."
- I'd switch the two bullet points above ^^, to help make it clear that statement is referring to the WAR/EJB statement (as the lib/parent module doesn't have a dependency on itself)
- The implicit dependencies on "EJB JAR subdeployments" info should be added back in, although maybe reworded to "non-WAR subdeployments" and made clear only that part is related to vv
- "The implicit dependencies described above occur because JBoss EAP 6 has subdeployment class loader isolation disabled by default." needs to be clear it's referring to the implicit dependencies on the non-WAR subdeployments
Comment 12 dereed 2015-07-27 11:38:11 EDT
The latest version looks great.

-Dennis
Comment 15 Martin Simka 2015-09-10 06:11:41 EDT
verified
Development Guide Revision 6.4.0-37

Note You need to log in before you can comment on or make changes to this bug.