This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1016352 - Update quickstart and Maven configuration for EAP 6.2
Update quickstart and Maven configuration for EAP 6.2
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: GA
: EAP 6.2.0
Assigned To: sgilda
Russell Dickenson
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-07 22:13 EDT by sgilda
Modified: 2014-08-14 11:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:48:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgilda: needinfo-


Attachments (Terms of Use)

  None (edit)
Description sgilda 2013-10-07 22:13:26 EDT
Description of problem:

The Development Guide contains instructions for the quickstarts and for configuring the Maven settings. With EAP 6.2, the Maven artifacts will be available online and we no longer require a download of hte Maven repository.

We need to make sure we update this information for EAP 6.2.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 3 sgilda 2013-12-02 15:24:15 EST
I'll take this one. I thought I had reassigned it when I created it, 

This will impact a few topics.

"Install the JBoss EAP 6 Maven Repository Locally", topic 5707: 
This procedure used to be required. Now that the repository is online, this step is not necessary. We need to make that clear.

"Access the Quickstarts", topic 5720: 
The prerequisite to download and install the Maven repository is now optional.

"Configure the JBoss EAP 6 Maven Repository Using the Maven Settings", topic 5709:
Add procedures to use the local repository.

These are the topic revisions:

Install the JBoss EAP 6 Maven Repository Locally [5707, rev: 562859]
Access the Quickstarts [5720, rev: 562864]
Configure the JBoss EAP 6 Maven Repository Using the Maven Settings [5709, rev: 562921]

I updated the Development Guide for EAP 6.3:
Development Guide for EAP 6.2: 14875

I need to check with Russell about the following:
Development Guide for EAP 6.3: 22509
Comment 4 sgilda 2013-12-02 15:45:18 EST
Aakanksha, Somehow this bug was overlooked up until now. There is a new online repository available for EAP 6.2 and this was not documented. I think this fix needs to be made for the EAP 6.2 documentation. I've modified the above topics and will check with Russell tonight to see if it's too late to get them in.
Comment 5 sgilda 2013-12-02 16:37:18 EST
Missed an instance of EAP 6.1 in topic 5707. Updated the following:

Install the JBoss EAP 6 Maven Repository Locally [5707, rev: 562927]
Comment 7 Dominik Pospisil 2013-12-04 07:16:38 EST
Why is this issue filled against JPP? Is that by mistake or did I missed something?
Comment 8 sgilda 2013-12-04 07:36:29 EST
Because it was a mistake! Reassigned to JBoss EAP.
Comment 9 sgilda 2013-12-04 07:37:43 EST
Removed watchers from the bug.
Comment 10 Nikoleta Ziakova 2013-12-06 02:59:33 EST
Verified for EAP 6.2.0 GA

Note You need to log in before you can comment on or make changes to this bug.