This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1016372 - Bug: Comments are not greyed out unless hash is at beginning of line
Bug: Comments are not greyed out unless hash is at beginning of line
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Lee Newson
Misha H. Ali
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 00:28 EDT by Misha H. Ali
Modified: 2013-10-17 19:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:45:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Commented out lines (17.79 KB, image/png)
2013-10-08 00:28 EDT, Misha H. Ali
no flags Details

  None (edit)
Description Misha H. Ali 2013-10-08 00:28:03 EDT
Created attachment 809066 [details]
Commented out lines

Description of problem:

Not sure if this is a bug or by design, but commenting out a CSP map line in the CCMS UI should grey out the line, no matter where the # is, as long as it is before the contents of that line.

For example, the two lines commented out here should be greyed out.

# Section: New Name
#   New Topic [1223]

And the same should happen to these lines:

  # Section: Another Section
    # Some Other Topic [3434]

However, the latter does not grey out at all. See screenshot for how this looks at the moment.
Comment 1 Lee Newson 2013-10-08 00:32:37 EDT
Fixed in 1.2-SNAPSHOT build 201309100946

This has was actually fixed quite some time ago and is currently live in PressGang Next.
Comment 3 Misha H. Ali 2013-10-08 00:36:32 EDT
Waiting for the specified build to be pushed live to verify. And ACK on report a bug link.
Comment 4 Misha H. Ali 2013-10-08 00:42:53 EDT
Verified in CCMS Next. Commenting out content works as expected.
Comment 5 Lee Newson 2013-10-08 00:45:33 EDT
Thanks Misha, moving to RELEASE_PENDING until 1.2 is released.
Comment 6 Matthew Casperson 2013-10-14 19:48:46 EDT
Confirmed that comments with tabs, spaces, and a combination of both are still highlighted as comments.

Note You need to log in before you can comment on or make changes to this bug.