Bug 10164 - /etc/inputrc overrides user configuration
/etc/inputrc overrides user configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: setup (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-14 08:07 EST by Kjetil T. Homme
Modified: 2014-03-16 22:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-14 12:47:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kjetil T. Homme 2000-03-14 08:07:27 EST
/etc/profile sets INPUTRC, which causes readline to ignore
~/.inputrc.  Not very popular with my users :-)
One fix is to use the undocumented(!) keyword $include at
the end of /etc/inputrc:

$include ~/.inputrc

Works for me.
Comment 1 Kjetil T. Homme 2000-03-14 09:47:59 EST
The suggested fix only works for bash 2.  But I consider it a bug
that /bin/bash still is 1.14, anyway.  :-)
(The fix has no ill effects for bash 1.14 that I can see.)
Comment 2 Bill Nottingham 2000-03-14 12:47:59 EST
This is fixed in the current setup package; /etc/inputrc
is only used if $HOME/.inputrc doesn't exist.

Note You need to log in before you can comment on or make changes to this bug.