Bug 1016400 - yumex crash when network manager not used
yumex crash when network manager not used
Status: CLOSED DUPLICATE of bug 1015039
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 02:08 EDT by Per Arnold Blåsmo
Modified: 2013-10-08 06:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-08 06:20:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Per Arnold Blåsmo 2013-10-08 02:08:16 EDT
Description of problem:
When running Fedora with network manager disabled, yumex fails with bad exception handling.

Version-Release number of selected component (if applicable):
yumex-3.0.12-1.fc19.noarch

How reproducible:


Steps to Reproduce:
1. Run with network manager disabled
2. Start yumex
3.

Actual results:
$ yumex
08:03:17 : INFO - Using config file : /home/<user>/.config/yumex/yumex.conf
08:03:17 : INFO - Using config file : /home/<user>/.config/yumex/yumex.conf
Traceback (most recent call last):
  File "/usr/bin/yumex", line 62, in <module>
    app = YumexApplication(backend)
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 211, in __init__
    Controller.__init__(self, BUILDER_FILE , 'main', domain='yumex')
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 280, in __init__
    self.ui.connect_signals(self._getAllMethods())
  File "/usr/lib/python2.7/site-packages/guihelpers/__init__.py", line 310, in _getAllMethods
    value = getattr(self, name)
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 260, in is_offline
    rc = self._network.check_network_connection()
  File "/usr/lib/python2.7/site-packages/yumexbase/network.py", line 92, in check_network_connection
    print str(e)
NameError: global name 'e' is not defined


Expected results:
yumex starts as normal.

Additional info:

Changing line 89 from: 
 except: # Catch all exceptions
to
 except Exception as e : # Catch all exceptions

Fixes the problem
Comment 1 Tim Lauridsen 2013-10-08 06:20:05 EDT

*** This bug has been marked as a duplicate of bug 1015039 ***

Note You need to log in before you can comment on or make changes to this bug.