Bug 1016403 - ear-deployment example cannot be deployed because of dependencies
ear-deployment example cannot be deployed because of dependencies
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 02:14 EDT by Jiri Sedlacek
Modified: 2015-08-02 19:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-15 02:49:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Sedlacek 2013-10-08 02:14:54 EDT
output of mvn jboss-as:deploy command, my settings.xml is pointing to local trimmed repo for ER4 and to http://maven.repository.redhat.com/techpreview/all/

jsedlace@nurik:~/soa6/servers/ER4/jboss-eap-6.1/quickstarts/switchyard/ear-deployment/ear-assembly$ mvn jboss-as:deploy 

[INFO] Scanning for projects...
[WARNING] The POM for org.apache.maven.archetype:archetype-packaging:jar:2.2-redhat-1 is missing, no dependency information available
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.archetype:archetype-packaging:2.2-redhat-1: Plugin org.apache.maven.archetype:archetype-packaging:2.2-redhat-1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.archetype:archetype-packaging:jar:2.2-redhat-1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.doxia:doxia-module-markdown:1.3-redhat-1: Failed to parse plugin descriptor for org.apache.maven.doxia:doxia-module-markdown:1.3-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/org/apache/maven/doxia/doxia-module-markdown/1.3-redhat-1/doxia-module-markdown-1.3-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] Failed to retrieve plugin descriptor for maven:maven-jdiff-plugin:1.5-redhat-1: Failed to parse plugin descriptor for maven:maven-jdiff-plugin:1.5-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/maven/maven-jdiff-plugin/1.5-redhat-1/maven-jdiff-plugin-1.5-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] Failed to retrieve plugin descriptor for maven:maven-xdoc-plugin:1.9.2-redhat-1: Failed to parse plugin descriptor for maven:maven-xdoc-plugin:1.9.2-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/maven/maven-xdoc-plugin/1.9.2-redhat-1/maven-xdoc-plugin-1.9.2-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is missing, no dependency information available
[WARNING] Failed to retrieve plugin descriptor for org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
[INFO]                                                                         
[INFO] ------------------------------------------------------------------------
[INFO] Building Quickstart : EAR Deployment - Application Assembly 1.1.0.M3-redhat-2
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.apache.maven.archetype:archetype-packaging:jar:2.2-redhat-1 is missing, no dependency information available
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.archetype:archetype-packaging:2.2-redhat-1: Plugin org.apache.maven.archetype:archetype-packaging:2.2-redhat-1 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.apache.maven.archetype:archetype-packaging:jar:2.2-redhat-1
[WARNING] Failed to retrieve plugin descriptor for org.apache.maven.doxia:doxia-module-markdown:1.3-redhat-1: Failed to parse plugin descriptor for org.apache.maven.doxia:doxia-module-markdown:1.3-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/org/apache/maven/doxia/doxia-module-markdown/1.3-redhat-1/doxia-module-markdown-1.3-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] Failed to retrieve plugin descriptor for maven:maven-jdiff-plugin:1.5-redhat-1: Failed to parse plugin descriptor for maven:maven-jdiff-plugin:1.5-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/maven/maven-jdiff-plugin/1.5-redhat-1/maven-jdiff-plugin-1.5-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] Failed to retrieve plugin descriptor for maven:maven-xdoc-plugin:1.9.2-redhat-1: Failed to parse plugin descriptor for maven:maven-xdoc-plugin:1.9.2-redhat-1 (/home/jsedlace/soa/esb_soa_tests/ledegen/integration/localRepo/maven/maven-xdoc-plugin/1.9.2-redhat-1/maven-xdoc-plugin-1.9.2-redhat-1.jar): No plugin descriptor found at META-INF/maven/plugin.xml
[WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is missing, no dependency information available
[WARNING] Failed to retrieve plugin descriptor for org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could not be resolved: Failed to read artifact descriptor for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
[INFO] 
[INFO] >>> jboss-as-maven-plugin:7.4.Final:deploy (default-cli) @ switchyard-quickstart-ear-deployment-assembly >>>
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 2.452s
[INFO] Finished at: Tue Oct 08 08:06:18 CEST 2013
[INFO] Final Memory: 24M/336M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal on project switchyard-quickstart-ear-deployment-assembly: Could not resolve dependencies for project org.switchyard.quickstarts:switchyard-quickstart-ear-deployment-assembly:ear:1.1.0.M3-redhat-2: Failed to collect dependencies for [org.switchyard.quickstarts:switchyard-quickstart-ear-deployment-artifacts:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts:switchyard-quickstart-ear-deployment-order-consumer:jar:1.1.0.M3-redhat-2 (compile), org.switchyard.quickstarts:switchyard-quickstart-ear-deployment-order-service:jar:1.1.0.M3-redhat-2 (compile)]: Failed to read artifact descriptor for org.switchyard.quickstarts:switchyard-quickstart-ear-deployment-artifacts:jar:1.1.0.M3-redhat-2: Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository, resolution will not be reattempted until the update interval of redhat-techpreview-all-repository has elapsed or updates are forced -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
Comment 1 Keith Babo 2013-10-14 12:41:47 EDT
This error seems to suggest the parent POM was not found.  Are you seeing this in all of the quickstarts or just this one? 

Failure to find org.switchyard.quickstarts:switchyard-quickstart-parent:pom:1.1.0.M3-redhat-2 in http://maven.repository.redhat.com/techpreview/all/ was cached in the local repository


I would expect the same issue to fail all quickstarts.  If that's what's happening, the the maven repo itself of the settings.xml is likely the culprit.
Comment 2 Jiri Sedlacek 2013-10-15 02:49:54 EDT
Now the jboss-as:deploy task passes. I was pretty sure I'd tried it with clean local repository and settings.xml pointing to correct repos, but obviously problem was on my side.

Marking as not a bug and closing.

Note You need to log in before you can comment on or make changes to this bug.