Bug 1016429 - win8 64 guest s4 fails with qxl
win8 64 guest s4 fails with qxl
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
Fixed_Not_Ship
:
Depends On:
Blocks: 912287
  Show dependency treegraph
 
Reported: 2013-10-08 03:29 EDT by Shaolong Hu
Modified: 2016-02-03 21:49 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-03 21:49:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shaolong Hu 2013-10-08 03:29:16 EDT
Description of problem:
------------------------
win8 64 guest s4 fails with qxl, guest restart instead of recovering from s4. This is an known issue, but in RHEL6, we don't have a bug to track this problem. Btw, with default vga and vnc, s4 works correctly.

I fail to locate qxl component name, report under qemu-kvm, feel free to change it.


Version-Release number of selected component (if applicable):
---------------------------------------------------------------
virtio-win-1.6.6-1.el6
qxlwddm-0.2-1
qemu-kvm-rhev-0.12.1.2-2.406.el6.x86_64


How reproducible:
------------------
100%


Steps to Reproduce:
--------------------
1.CMD:

/usr/libexec/qemu-kvm -enable-kvm -M rhel6.5.0 -smp 4 -m 4G -name rhel6.3-64 -uuid 3f2ea5cd-3d29-48ff-aab2-23df1b6ae213 -drive file=win8-64-virtio.qcow2,cache=none,if=none,rerror=stop,werror=stop,id=drive-virtio-disk0,format=qcow2,aio=native -device virtio-blk-pci,drive=drive-virtio-disk0,id=device-virtio-disk0,bootindex=1 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=aa:54:00:11:22:33 -boot order=cd -monitor stdio -readconfig ich9-ehci-uhci.cfg -device usb-tablet,id=input0 -chardev socket,id=s1,path=/tmp/s1,server,nowait -device isa-serial,chardev=s1 -monitor tcp::1234,server,nowait -device usb-hub,id=hub -device usb-storage,drive=drive-usb1,id=device-usb1,removable=on -drive  file=disk1,if=none,id=drive-usb1,media=disk,format=qcow2,cache=none,aio=threads -device usb-kbd,id=usb-kbd -device usb-mouse,id=usb-mouse -vga qxl -global qxl-vga.revision=3 -spice port=5920,disable-ticketing -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0

2.
(qemu) system_powerdown 


Actual results:
------------------
re-run qemu-kvm with same CMD, guest restart instead of recovering from s4.
Comment 1 Shaolong Hu 2013-10-08 03:37:08 EDT
before step 2, change behavior of close computer button to "hibernate"
Comment 3 Qunfang Zhang 2013-10-08 04:38:29 EDT
As default vga and vnc works well for s4, so please help move to correct component if we are wrong. Filed to qemu-kvm first because we need bz to track the issue and we are not sure which is the proper component for the new qxlwddm build.  Thanks.
Comment 4 Ademar Reis 2013-10-08 09:48:12 EDT
See also Bug 1016433
Comment 7 lijin 2014-06-17 01:42:06 EDT
cannot reproduce this issue,guest can s4 and resume successfully.

package info:
qemu-kvm-rhev-0.12.1.2-2.406.el6.x86_64
qxlwddm-0.2-1
virtio-win-1.6.6-1.el6.noarch
kernel-2.6.32-477.el6.x86_64
spice-server-0.12.4-9.el6.x86_64

steps:
1.boot win8-64 guest with:
/usr/libexec/qemu-kvm -enable-kvm -M rhel6.5.0 -smp 2 -m 2G -drive file=win8-64.qcow2,format=qcow2,if=none,cache=none,rerror=stop,werror=stop,id=drive1,media=disk -device virtio-blk-pci,drive=drive1,id=disk1,bootindex=1 -usb -device usb-tablet -monitor stdio -fda /usr/share/virtio-win/virtio-win_amd64.vfd -boot menu=on -vga qxl -global qxl-vga.revision=3 -spice port=5920,disable-ticketing -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -netdev tap,script=/etc/qemu-ifup,id=netdev0 -device virtio-net-pci,netdev=netdev0,id=device-net0,mac=aa:54:00:12:22:00 -cdrom /usr/share/virtio-win/virtio-win.iso
2.change behavior of close computer button to "hibernate"
3.(qemu) system_powerdown 
4.boot guest with the same command in step1

actual result:
guest can hibernate after step3 and can resume correctly after step4
Comment 11 lijin 2014-08-27 05:18:17 EDT
retest with qxlwddm-0.1-6,steps as comment #7,guest can hibernate and resume correctly.

So this issue has been fixed already.
Comment 12 lijin 2015-07-17 03:47:30 EDT
change status to verified according to comment#11

Note You need to log in before you can comment on or make changes to this bug.