Bug 1016434 - Extension sphinxcontrib.httpdomain could not be imported
Extension sphinxcontrib.httpdomain could not be imported
Status: CLOSED CURRENTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-sphinxcontrib-httpdomain (Show other bugs)
el6
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Callaghan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 03:45 EDT by Lokesh Mandvekar
Modified: 2015-01-27 11:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-27 11:32:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lokesh Mandvekar 2013-10-08 03:45:47 EDT
Description of problem:
while building docs for docker-io, python-sphinx isn't able to import extension sphinxcontrib.httpdomain

Version-Release number of selected component (if applicable): 0.6.6


How reproducible: Always


Steps to Reproduce: 
1. rpmbuild -ba docker-io.spec (specifically: make -C docs/ man)


Actual results:
+ make -C docs/ man
make: Entering directory `/home/lsm5/repositories/rpmbuild/BUILD/docker-0.7-rc2/docs'
sphinx-build -b man -d _build/doctrees   sources _build/man
Making output directory...
Running Sphinx v0.6.6

Extension error:
Could not import extension sphinxcontrib.httpdomain (exception: cannot import name XRefRole)
make: *** [man] Error 1
make: Leaving directory `/home/lsm5/repositories/rpmbuild/BUILD/docker-0.7-rc2/docs'




Expected results: This is the equivalent on Fedora rawhide
+ make -C docs/ man
make: Entering directory `/home/lsm5/repositories/rpmbuild/BUILD/docker-0.7-rc2/docs'
sphinx-build -b man -d _build/doctrees   sources _build/man
Making output directory...
Running Sphinx v1.1.3
loading pickled environment... not yet created
Comment 1 Toshio Ernie Kuratomi 2013-10-08 09:48:52 EDT
Note, this is misfiled:

1) the version of sphinx that you are using comes from RHEL, not from EPEL.

2) part of the problem is the packaging of python-sphinxcontrib-httpdomain: The package in EPEL is lacking a Requires: python-sphinx10

3) Part of the problem is likely in the docker-io package.  If you run the sphinx-0.6.6 version of the sphinx-build tool it will be unable to load the extension because the extension uses a feature of newer python-sphinx.  Probably you need to patch the code to use sphinx-1.0-build

Retargeting bug to python-sphinxcontrib-httpdomain for the Requires issue.  To help with the docker-io build failure, I'd need to see the docker-io package you're building.
Comment 2 Dan Callaghan 2013-10-08 21:44:24 EDT
I've updated the Requires for python-sphinxcontrib-httpdomain although that won't stop people from trying to use it with Sphinx 0.6. I don't think there is any good way to do that.
Comment 3 Fedora Update System 2013-10-08 22:01:09 EDT
python-sphinxcontrib-httpdomain-1.1.8-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-sphinxcontrib-httpdomain-1.1.8-3.el6
Comment 4 Fedora Update System 2013-10-08 22:01:53 EDT
python-sphinxcontrib-httpdomain-1.1.8-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/python-sphinxcontrib-httpdomain-1.1.8-3.el5
Comment 5 Fedora Update System 2013-11-11 13:32:26 EST
python-sphinxcontrib-httpdomain-1.1.8-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2013-11-11 13:32:44 EST
python-sphinxcontrib-httpdomain-1.1.8-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.