This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1016465 - blockdev-setbsz succeeds, but does not affect blockdev-getbsz
blockdev-setbsz succeeds, but does not affect blockdev-getbsz
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libguestfs (Show other bugs)
7.0
All Linux
low Severity low
: rc
: ---
Assigned To: Richard W.M. Jones
Virtualization Bugs
:
Depends On: 624334
Blocks: 624335
  Show dependency treegraph
 
Reported: 2013-10-08 04:39 EDT by Richard W.M. Jones
Modified: 2014-06-17 22:01 EDT (History)
6 users (show)

See Also:
Fixed In Version: libguestfs-1.22.6-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 624334
Environment:
Last Closed: 2014-06-13 05:29:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2013-10-08 04:39:01 EDT
+++ This bug was initially created as a clone of Bug #624334 +++

Version-Release number of selected component (if applicable):
1.5.2

How reproducible:
Always

Steps to Reproduce:
$ guestfish -a test.img
...
><fs> blockdev-getbsz /dev/sda
4096
><fs> blockdev-setbsz /dev/sda 2048
><fs> blockdev-getbsz /dev/sda
4096

Expected results:
blockdev-getbsz should return the latest block size we just set, or the blockdev-setbsz should return an error if the block size is not supported.

--- Additional comment from Richard W.M. Jones on 2013-09-20 04:53:12 EDT ---

https://bugzilla.redhat.com/show_bug.cgi?id=1002825 sheds more
light on this issue.

---

We should deprecate these calls and document
that they never worked.
Comment 2 Richard W.M. Jones 2013-10-16 08:31:37 EDT
commit 4fc44a0157a1bcd4c618e0eb8afd7c553ed0f31d
Author: Richard W.M. Jones <rjones@redhat.com>
Date:   Tue Oct 8 10:00:33 2013 +0100

    blockdev: Deprecate blockdev_setbsz and make it do nothing (RHBZ#624334).
    
    This call never did anything.  Don't use it.  Also I have submitted a
    patch upstream to remove the corresponding option from blockdev.
    
    See RHBZ#1002825 for an explanation of why this call was always
    useless.
    
    Thanks: Masayoshi Mizuma
Comment 4 Richard W.M. Jones 2013-10-16 14:56:39 EDT
libguestfs-1.22.6-12.el7
http://brewweb.devel.redhat.com/brew/taskinfo?taskID=6429251
Comment 5 Can Zhang 2013-11-10 22:12:35 EST
The man page of `guestfish` has documented `blockdev-setbsz` as "Do not use it", so I think it could be considered as "verified". Also, further works like fully removal of the API should be applied.
Comment 6 Richard W.M. Jones 2013-11-11 03:22:06 EST
(In reply to Can Zhang from comment #5)
> The man page of `guestfish` has documented `blockdev-setbsz` as "Do not use
> it", so I think it could be considered as "verified". Also, further works
> like fully removal of the API should be applied.

APIs cannot be removed, because that would cause an ABI break
which we never do in libguestfs.
Comment 7 Ludek Smid 2014-06-13 05:29:43 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.