Bug 1016485 - jboss-eap-6.0.0.fsw.ci-installer - Problem with connecting to DB if atypical installation path was chosen
jboss-eap-6.0.0.fsw.ci-installer - Problem with connecting to DB if atypical ...
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: CR1
: 6.0.0
Assigned To: Miles Tjandrawidjaja
Len DiMaggio
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 05:02 EDT by Martin Basovník
Modified: 2016-11-30 19:55 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This error is thrown while connecting to Management Interface. (82.26 KB, image/png)
2013-10-08 05:02 EDT, Martin Basovník
no flags Details
Screenshot #3 (96.99 KB, image/png)
2014-01-06 15:29 EST, Len DiMaggio
no flags Details
Screenshot #2 (37.82 KB, image/png)
2014-01-06 15:29 EST, Len DiMaggio
no flags Details
Screenshot #1 (101.63 KB, image/png)
2014-01-06 15:29 EST, Len DiMaggio
no flags Details

  None (edit)
Description Martin Basovník 2013-10-08 05:02:38 EDT
Created attachment 809183 [details]
This error is thrown while connecting to Management Interface.

Description of problem:
Problem with connecting to database when setting "atypical" installation path.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Select the installation path: /home/mbasovni/development/test//\0/,:|; (change your home folder)
3. Do not change any settings.
2. Do not change default database configuration
jdbc:h2://home/mbasovni/development/test/\0/,:|;/jboss-eap-6.1/standalone/data/h2/soa;mvcc=true


Actual results:


Successfully added administrative user account.
Starting Application Server.
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /home/mbasovni/development/test/

  JAVA: /usr/lib/jvm/default-java//bin/java

  JAVA_OPTS: -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================

Trying to connect to Management Interface...(1/5).
Trying to connect to Management Interface...(2/5).
Trying to connect to Management Interface...(3/5).
Trying to connect to Management Interface...(4/5).
Trying to connect to Management Interface...(5/5).
Failed to connect to Management Interface after 5 attempts.
Running onfail Server Check.
Shutting server down.
Trying to connect to Management Interface...(1/5).
Trying to connect to Management Interface...(2/5).
Trying to connect to Management Interface...(3/5).
Trying to connect to Management Interface...(4/5).
Trying to connect to Management Interface...(5/5).
Failed to connect to Management Interface after 5 attempts.


Finally an error window is thrown (attachment).

Expected results:
Server will start up.

Additional info:
Comment 1 Thomas Hauser 2013-10-21 14:01:32 EDT
I cannot run the server at all from a location like the one you have used in this test. An unzip of EAP 6.1 into such a location fails to launch the server. Since this is the case, I think that we should lean towards adding validation to the path, and warning the user that a path containing certain values is likely to cause issues among the multitude of components that make up FSW.
Comment 2 Martin Basovník 2013-10-22 05:20:54 EDT
I agree. I think it is appropriate solution.
Comment 3 Thomas Hauser 2013-10-23 11:33:34 EDT
The install path in post-beta builds will no longer allow the following characters:

\0
;
,
|
:

Note: Not all of them caused problems on my local machine. On unix, the only ones that caused failures were \0 ; and :. It is probably best, however, to not allow any characters like this to be used.
Comment 4 Len DiMaggio 2014-01-06 14:30:16 EST
Re-opened - still an issue in ER8.
Comment 5 Len DiMaggio 2014-01-06 15:29:13 EST
Created attachment 846294 [details]
Screenshot #3
Comment 6 Len DiMaggio 2014-01-06 15:29:34 EST
Created attachment 846295 [details]
Screenshot #2
Comment 7 Len DiMaggio 2014-01-06 15:29:55 EST
Created attachment 846296 [details]
Screenshot #1
Comment 8 Miles Tjandrawidjaja 2014-01-06 17:07:08 EST
Added validation to target path.

http://git.app.eng.bos.redhat.com/fsw-installer.git/commit/?id=87cd87a6010998147b9962891cb714cb0f2afd64
Comment 9 Pavol Srna 2014-01-15 03:24:22 EST
Verified in CR1 build.

Note You need to log in before you can comment on or make changes to this bug.