Bug 1016503 - RHQ Server resource is not recognized after upgrade
RHQ Server resource is not recognized after upgrade
Status: CLOSED NOTABUG
Product: JBoss Operations Network
Classification: JBoss
Component: Upgrade (Show other bugs)
JON 3.2
Unspecified Unspecified
high Severity high
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks: 1012435
  Show dependency treegraph
 
Reported: 2013-10-08 05:45 EDT by Libor Zoubek
Modified: 2015-11-01 19:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 03:48:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Libor Zoubek 2013-10-08 05:45:37 EDT
Description of problem:

When upgrading from JON 3.1.2 new server does not detect (and thatswhy treat differently) EAP as RHQ Server.

Version-Release number of selected component (if applicable):
JON 3.2.ER3

How reproducible: always


Steps to Reproduce:
1. install JON 3.1.2, import local agent and all resources
2. upgrade to JON 3.2.ER3
- unzip jon-server-3.2.ER3.zip
- cd bin, ./rhqctl stop --agent # stop agent
- stop JON 3.1.2 server
- upgrade : ./rhqctl upgrade --from-server-dir=/home/hudson/jon-server-3.1.2.GA/
- start everything (I started server & storage, then I logged in to server and found out agent was down, so started agent afterwards)
3. look at discovery queue and import RHQ Server

Actual results:

In discovery queue, you can find "EAP (127.0.0.1:6990)" which seems to be handled as regular EAP. If you import such resource, it won't come UP because default management password won't not work.

Expected results: RHQ server resource must appear as "EAP (127.0.0.1:6990) RHQ Server" and when imported, it must go GREEN.
Comment 1 Libor Zoubek 2013-10-08 06:21:49 EDT
Just tried once again, and Steps to reproduce can be easier, basically it happens when regular upgrade is done.
Comment 2 John Mazzitelli 2013-10-08 13:27:52 EDT
(In reply to Libor Zoubek from comment #1)
> Just tried once again, and Steps to reproduce can be easier, basically it
> happens when regular upgrade is done.

can you explain what you mean by "when regular upgrade is done" ? How was the upgrade steps in the issue's description not a regular upgrade?
Comment 3 John Mazzitelli 2013-10-08 13:56:23 EDT
Can you confirm that you installed the "rhq-server" plugin? Without that plugin you can't detect RHQ Server resources.
Comment 4 Libor Zoubek 2013-10-09 08:35:13 EDT
Regular update (as I did it) was:

- have JON 3.1.2 with all pluginpacks

- unzip jon-server-3.2.ER3.zip
 stop old agent
- stop JON 3.1.2 server
- upgrade : ./rhqctl upgrade --from-server-dir=/home/hudson/jon-server-3.1.2.GA/
- start everything ./rhqctl start --agent --storage --server

about "rhq-server" plugin, I just found out, my JON 3.1.2 installation had all plugin-packs, but when upgrading I forgot about 3.2 pluginpacks.  If our rhq-server plugin extends AS7 plugin and I did not upgrade AS7 plugin from plugin pack, we're in bad situation. AS7 plugin should probably be shipped within JON as it is required by RHQ Server plugin. If I was a customer having JON without AS7 plugin I wouldn't have even discovered RHQ Server after upgrading to JON 3.2.

After upgrade:

RHQ Server plugin and AS7 plugin were not upgraded and are still in 312 versions.

I just verified situation when I unzip all pluginpacks to /plugins before running upgrade .. then RHQ Server is correctly discovered.
Comment 5 John Mazzitelli 2013-10-15 14:38:43 EDT
(In reply to Libor Zoubek from comment #4)
> Regular update (as I did it) was:
> 
> - have JON 3.1.2 with all pluginpacks
> 
> - unzip jon-server-3.2.ER3.zip
>  stop old agent
> - stop JON 3.1.2 server
> - upgrade : ./rhqctl upgrade
> --from-server-dir=/home/hudson/jon-server-3.1.2.GA/
> - start everything ./rhqctl start --agent --storage --server
> 
> about "rhq-server" plugin, I just found out, my JON 3.1.2 installation had
> all plugin-packs, but when upgrading I forgot about 3.2 pluginpacks.  If our
> rhq-server plugin extends AS7 plugin and I did not upgrade AS7 plugin from
> plugin pack, we're in bad situation. AS7 plugin should probably be shipped
> within JON as it is required by RHQ Server plugin. If I was a customer
> having JON without AS7 plugin I wouldn't have even discovered RHQ Server
> after upgrading to JON 3.2.
> 
> After upgrade:
> 
> RHQ Server plugin and AS7 plugin were not upgraded and are still in 312
> versions.
> 
> I just verified situation when I unzip all pluginpacks to /plugins before
> running upgrade .. then RHQ Server is correctly discovered.

Yes, so for sure, you need to have the JBoss AS7 plugin in order to discover the new JON 3.2 RHQ Server resource since we now run on AS7. If you did not have that plugin before, you will no longer detect the RHQ Server resource.

This is analogous to our earlier requirement that you must have the AS4 plugin to detect the RHQ Server (since we ran on AS 4.2.3 in earlier JON versions).
Comment 6 John Mazzitelli 2013-10-15 15:09:38 EDT
some other notes:

1) the 3.1.2 rhq-server plugin required the AS4 plugin. This is essentially what we will have in 3.2 - except the rhq-server plugin will require the AS7 plugin, rather than the AS4 plugin

2) the rhq-server plugin didn't come with JON out of box - the rhq-server plugin shipped with the EAP plugin pack (so it came with the AS4 plugin since EAP plugin pack had the AS4 plugin as well). We should therefore ship the rhq-server plugin again with the 3.2 EAP plugin pack that also comes with the AS7 plugin. But I think this is what we've always done (that is, ship rhq-server plugin in the plugin pack that had its AS plugin)

3) You've always needed to upgrade the plugin pack along with the JON server. So I don't think this is any different from before. For example, when you upgrade from 3.1 to 3.1.2, I think you needed to upgrade the plugin packs from their 3.1 versions to 3.1.2 as well. The same will hold true still - if you have 3.1.2 EAP plugin pack, you need to upgrade to the 3.2 EAP plugin pack. And when you do, you will get the AS7 plugin as well as the rhq-server plugin.

So, in short, upgrading the EAP plugin pack along with JON when going to 3.2 will ensure everything works. Without upgrading the plugin pack, you won't get the new functionality (and thus you won't get the new RHQ Server resource since it needs the new AS7 functionality) but this goes against our documentation.

I think this "works as designed" - we should probably close this BZ unless there is something else I'm missing.
Comment 7 John Mazzitelli 2013-10-18 11:23:18 EDT
unassigning myself - I think we can close this as it appears to be working as expected/designed.
Comment 8 Libor Zoubek 2013-10-21 03:48:45 EDT
Mazz, thanks for explanation. It really works as expected. The only thing I don't understand is existence of AS7 plugin pack, because every customer has to install it anyway

Note You need to log in before you can comment on or make changes to this bug.