Bug 1016517 - Unable to build project even if the invalid rule is deleted
Unable to build project even if the invalid rule is deleted
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high
: ER5
: 6.0.0
Assigned To: manstis
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 06:06 EDT by Sona Mala
Modified: 2014-08-06 16:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:20:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
server.log (210.49 KB, text/x-log)
2013-10-08 06:06 EDT, Sona Mala
no flags Details

  None (edit)
Description Sona Mala 2013-10-08 06:06:10 EDT
Created attachment 809190 [details]
server.log

Description of problem:
The project which once contains invalid rule is unable to build even if the rule is deleted. The Problems tab shows problem with non-existent rule.


Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER3

How reproducible:


Steps to Reproduce:
1. create new repository "myRepo", new project "org.jboss.qa.myProject"
2. build the project
3. create guided rule in package "org.jboss.qa.myProject"
4. show options
5. add new option "timer" with value "xx xx xx"
6. save the rule
7. build the project
8. delete rule
9. build the project

Actual results:
Step 2: build is success
Step 7, 9: build fails

All actions, which are connected with this non-existent rule (as run testscenario, switch the project, etc.), failed with "Incorrect number of arguments for interval timer 'xx xx xx'" in the Problems tab.

Test scenario which name is "test" shows "test" issue in the Reports tab.


Expected results:
Step 2,9: build is success
Step 7: build failed

The build of the project should not depend on non-existent rule. 

Additional info:
Refresh the browser, log out/in the user and switching the user do not help.
Git repository really does not contain this rule.
Restart of server helps. But I believe that the user should not restart the server every time when he deletes some rule.

Enumeration's assets seems to be affected by this issue.
Comment 2 Sona Mala 2013-12-17 09:59:36 EST
Verified for ER5

Note You need to log in before you can comment on or make changes to this bug.