Bug 101655 - Changed XSLT files are not reloaded
Summary: Changed XSLT files are not reloaded
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Web Application Framework
Classification: Retired
Component: other (Show other bugs)
(Show other bugs)
Version: nightly
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: ccm-bugs-list
QA Contact: Jon Orris
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 101458
TreeView+ depends on / blocked
 
Reported: 2003-08-05 09:37 UTC by Daniel Berrange
Modified: 2007-04-18 16:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-13 21:55:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Berrange 2003-08-05 09:37:06 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.9 (X11; Linux i686; U;) Gecko/20030314

Description of problem:
When the merge of the new presentation manager was done, the ability for it to
detect changed XSLT files & reload the templates was removed. This functionality
is crucial to developers because without it, every single XSL change requires
restarting the server. This literally destroys productivity, because each 'edit,
deploy, view' cycle now takes several minutes instead of a mere 30 seconds.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start the server & visit a page, eg /admin/
2. Make a change to the stylesheet for /admin
3. Run ant deploy
4. Visit the page again, /admin/
    

Actual Results:  The change to the XSLT does not appear

Expected Results:  The change to the XSLT is visible.

Additional info:

See featurezilla http://bugzilla.redhat.com/bugzilla/show_bug.cgi?format=ft&id=98409

Comment 1 Justin Ross 2003-08-12 22:13:04 UTC
Fixed in perforce change 34575.  I spent some time testing the change to show
that it

a) doesn't change the current behavior at all if debugMode = false
b) supposing debugMode is on, only reloads when a file has been touched

It looks to be in good shape.




Note You need to log in before you can comment on or make changes to this bug.