Bug 1016576 - btrfs manpage: need detailed descriptions about command "filesystem balance"
btrfs manpage: need detailed descriptions about command "filesystem balance"
Status: CLOSED DUPLICATE of bug 1134981
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: btrfs-progs (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: fs-maint
Filesystem QE
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 07:13 EDT by Eryu Guan
Modified: 2014-10-15 19:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: btrfs-progs-3.16-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-15 19:15:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2013-10-08 07:13:43 EDT
Description of problem:
We have very simple description about "filesystem balance" command, need more detailed descriptions about:

btrfs fi balance start
btrfs fi balance pause
btrfs fi balance cancel
btrfs fi balance resume
btrfs fi balance status
(described at http://www.mail-archive.com/linux-btrfs@vger.kernel.org/msg14365.html)

And all filters as described at https://btrfs.wiki.kernel.org/index.php/Balance_Filters

Version-Release number of selected component (if applicable):
btrfs-progs-0.20.rc1.20130917git194aa4a-1.el7
upstream btrfs-progs too

How reproducible:
always

Steps to Reproduce:
1. man 8 btrfs and search for balance command
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Eric Sandeen 2014-07-14 19:40:26 EDT
This has moved to the btrfs-balance(8) manpage.

However, there is still no description of filters, for example.
Comment 3 Eric Sandeen 2014-10-15 19:15:09 EDT
Fixed in v3.16 with:

6c30bee btrfs-progs: Documentation: Add filter section for btrfs-balance.


Closing this and others with NEXTRELEASE since it's part of a rebase, but if you prefer we can re-open, get all the acks, and add it to the errata.  I'm not sure if that's worth it, but if you want to, please let me know.

Thanks,
-Eric
Comment 4 Eric Sandeen 2014-10-15 19:20:08 EDT
Actually, probably better to dup to the rebase bug.

*** This bug has been marked as a duplicate of bug 1134981 ***

Note You need to log in before you can comment on or make changes to this bug.