Bug 1016583 - mount manpage: need descriptions about btrfs mount options
mount manpage: need descriptions about btrfs mount options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: btrfs-progs (Show other bugs)
7.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Eric Sandeen
XuWang
: ManPageChange
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 07:21 EDT by Eryu Guan
Modified: 2015-03-05 08:13 EST (History)
5 users (show)

See Also:
Fixed In Version: btrfs-progs-3.16-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-03-05 08:13:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eryu Guan 2013-10-08 07:21:19 EDT
Description of problem:
There are no descriptions about btrfs mount options now in "man 8 mount"

https://btrfs.wiki.kernel.org/index.php/Mount_options

Version-Release number of selected component (if applicable):
util-linux-2.23.2-5.el7

How reproducible:
always

Steps to Reproduce:
1. man 8 mount and search btrfs
2.
3.

Actual results:
no mount options for btrfs

Expected results:
descriptions about btrfs mount options

Additional info:
I'm not sure if it should be a util-linux bug, maybe a btrfs-progs bug, please correct me if I was wrong.
Comment 1 Karel Zak 2013-10-08 07:40:43 EDT
I have a better idea, create "btrfs.5" man page as we already have for example for NFS. 

I don't think that add a new filesystem and increment number of fs-specific things in mount.8 is a good idea. I'd like to go in completely opposite direction and force FS maintainer to create <fstype>.5 man pages.
Comment 2 Eric Sandeen 2013-10-08 10:09:28 EDT
The mount options are (mostly) documented in kernel docs.

A quick & dirty translation to manpage format shouldn't be too bad.

I did the kernel docs, so I guess I'll take this bug.

-Eric
Comment 4 Eric Sandeen 2014-07-03 16:54:21 EDT
This will actually get done as part of the btrfs-progs rebase; we've moved fs-specific mount options for many filesystems into fs-specific manpages.

Karel, do we need to coordinate this with a mount(8) update?

-Eric
Comment 5 Eric Sandeen 2014-07-14 20:09:23 EDT
I've sent the patch to add mount options to btrfs manpages upstream, hopefully it'll make the next release.
Comment 6 Karel Zak 2014-07-17 04:59:29 EDT
Does it mean you want to backport the fs-specific man pages to RHEL7? If yes,
then it would be nice to remove the duplicate things from RHEL7 mount.8.


From upstream point of view we have to provide time for downstream distros to
adopt this change, so we're going to release v2.25 (probably next Monday) with
the classic mount.8 that also includes btrfs stuff. And I hope that v2.26 
(end of this year) will be without extN, XFS, btrfs (etc.) stuff in mount.8. 

Anyway, I don't see a problem to have the information on both places (e.g. 
btrfs.5 and mount.8) for short time before all distros update all the
packages. For RHEL7 we can coordinate all within one update.
Comment 7 Eric Sandeen 2014-07-17 10:36:50 EDT
Karel, I will probably backport the ext234/xfs/btrfs specific man pages for RHEL7, yes - actually, xfs is already done.  And we'll rebase btrfs-progs again, so just e2fsprogs remains, and it's on the acl this release, so may as well do it.
Comment 8 Eric Sandeen 2014-10-14 11:50:11 EDT
I forgot, this got done in 3.16:

BTRFS-MOUNT(5)                   Btrfs Manual                   BTRFS-MOUNT(5)

NAME
       btrfs-mount - mount options and supported file attributes for the btrfs filesystem

...

MOUNT OPTIONS
       alloc_start=bytes
           Debugging option to force all block allocations above a certain byte threshold on each block device. The
           value is specified in bytes, optionally with a K, M, or G suffix, case insensitive. Default is 1MB.

...
Comment 10 XuWang 2014-11-20 03:52:44 EST
I verify it in RHEL7.1, with the btrfs-progs-3.16.2-1.el7.x86_64.

type man 5 btrfs, and the map page shows like below:
BTRFS-MOUNT(5)                   Btrfs Manual                   BTRFS-MOUNT(5)

NAME
       btrfs-mount - mount options and supported file attributes for the btrfs
       filesystem

DESCRIPTION
       This document describes mount options specific to the btrfs filesystem.
       Other generic mount options are available,and are described in the
       mount(8) manpage.

MOUNT OPTIONS
       alloc_start=bytes
           Debugging option to force all block allocations above a certain
           byte threshold on each block device. The value is specified in
           bytes, optionally with a K, M, or G suffix, case insensitive.
           Default is 1MB.

So I think the status of this bug should be verified.
Comment 12 errata-xmlrpc 2015-03-05 08:13:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0534.html

Note You need to log in before you can comment on or make changes to this bug.