Bug 1016597 - Authentication failure during maven build/deploy of dtgov demos
Authentication failure during maven build/deploy of dtgov demos
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: DT Governance, Documentation, Examples (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ER7
: 6.0.0
Assigned To: Eric Wittmann
Stefan Bunciak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 07:38 EDT by Stefan Bunciak
Modified: 2014-01-30 17:31 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-30 17:31:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stefan Bunciak 2013-10-08 07:38:48 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install FSW 6.0.0.ER4
2. cd to quickstarts/dtgov-demos/dtgov-demos-switchyard 
3. workaround the https://bugzilla.redhat.com/show_bug.cgi?id=1016580 (by adding s-ramp-wagon to build extension in pom.xml)
4. Execute mvn -Pdemo clean deploy -Dsramp.auth.password=<pwd_you_provided_in_installer>

Actual results:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.5-redhat-1:deploy (default-deploy) on project dtgov-demos-switchyard: Failed to deploy artifacts: Could not transfer artifact org.overlord.dtgov.demos.switchyard:dtgov-demos-switchyard:jar:1.0.1.Final-redhat-4 from/to local-sramp-repo (sramp://localhost:8080/s-ramp-server/?artifactType=SwitchYardApplication): Failed to connect to the S-RAMP repository. Authentication failure while attempting to access the S-RAMP repository. -> [Help 1]



Expected results:


Additional info:

* s-ramp-wagon will probably need update to use the credentials provided by env property (-Dsramp.auth.password)
Comment 1 Eric Wittmann 2013-10-08 14:05:50 EDT
I believe this is a duplicate of:

  https://bugzilla.redhat.com/show_bug.cgi?id=1016495

See the comments for that bug, but basically I updated the Readme files for all mvn related demos to explain how authentication is handled.
Comment 3 Stefan Bunciak 2013-12-12 09:25:22 EST
Verified in FSW 6.0.0.ER7

Note You need to log in before you can comment on or make changes to this bug.