Bug 1016633 - abrt fails to login to bugzilla
abrt fails to login to bugzilla
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
18
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 08:57 EDT by morgan read
Modified: 2016-11-30 19:45 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-21 10:47:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description morgan read 2013-10-08 08:57:00 EDT
Description of problem:
Submit abrt report to https://bugzilla.redhat.com
Process fails, despite correct redhat BZ login and password, with:
Invalid password or login. Please enter your BZ login: 'mstuff@read.org.nz'
Invalid password or login. Please enter the password for 'mstuff@read.org.nz': '********'
Invalid password or login. Please enter your BZ login: ''
Can't continue without login
('report_Bugzilla' exited with 69)

Version-Release number of selected component (if applicable):
0.3.1

How reproducible:
Always

Steps to Reproduce:
1. Follow bug report submission process
2. Fails login with saved BZ login and password, prompt for BZ login and password
3. Enter correct BZ login and password

Actual results:
Redhat BZ login failure

Expected results:
Login and successful bug report submission

Additional info:
Frustration
Comment 1 Jakub Filak 2013-10-11 10:32:18 EDT
Thank you for the report. How reproducible is this? I did my best but I cannot reproduce it.

Please, in order to minimize probability of a typo problem, store your BZ credentials in the configuration before you try to reproduce this bug. You have a pair of possibilities how to do this:

1. edit /etc/libreport/plugins/bugzilla.conf
2. open ABRT GUI -> Application menu -> Preferences -> Events -> Bugzilla -> click Configure button -> (check Show password box)
Comment 2 morgan read 2013-10-14 05:54:41 EDT
I just reproduced this.  BZ credentials are in ABRT, checked same as stored in FF for web login to BZ.

Thanks.
Comment 3 Jakub Filak 2013-10-18 05:44:59 EDT
I just reported a bug from my fully updated F18 box. I temporarily changed my password to "G@fk8 R2tčw" and everything worked fine. Could you please change your password to something simpler and try to reproduce this bug again.

Have you set up any proxy servers in your browser?
Comment 4 morgan read 2013-10-21 07:16:31 EDT
OK, no - no proxies in browser etc
But, re report below - updated my password from "TTeoMMRluZFX" (complex) to v simple 6 digit password, and it worked fine...
So, I guess abrt doesn't like complex passwords...

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Invalid password or login. Please enter your BZ login: 'mstuff@read.org.nz'
Invalid password or login. Please enter the password for 'mstuff@read.org.nz': '********'
Checking for duplicates
Creating a new bug
New bug id: 1021468
Adding attachments to bug 1021468
Logging out
Status: NEW https://bugzilla.redhat.com/show_bug.cgi?id=1021468
Comment 5 morgan read 2013-10-21 07:20:05 EDT
Since reduced my 12 digit complex pword to a complex 10 digit pword.  Have to wait and see how that goes with my next abrt report.
Comment 6 Jakub Filak 2013-10-21 10:47:12 EDT
I am still able to report a bug to Bugzilla with "TTeoMMRluZFX" and even "TTeoMMRluZFXTTeoMMRluZFX". So, I would not say that abrt has a problem with long and complex passwords. 

It was probably a mysterious bug in Bugzilla itself which got fixed by changing your password. Closing as WORKSFORME, but reopen if the problem occurs again.

Note You need to log in before you can comment on or make changes to this bug.