Bug 1016639 - "Application Server successfully started." string is missing once starting server via installer
"Application Server successfully started." string is missing once starting se...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ER6
: EAP 6.2.0
Assigned To: Francisco Canas
Petr Kremensky
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-10-08 09:04 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-15 11:18:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-10-08 09:04:37 EDT
Description of problem:
 We should return "Application Server successfully started." string once starting server via installer. This is missing since EAP 6.2.0.ER3. 

Currently:
-gui
Next button change its state from disabled to enabled once the server is ready, but I am missing any server start message. 
-console
server logs are mixed with create shortcuts prompt.

Version-Release number of selected component (if applicable):
 EAP 6.2.0.ER5

How reproducible:
 always

Steps to Reproduce:
 1. Start -console installation
 2. Choose to start server on Server Launch dialog and continue
 3. Observe installer output on server startup

Actual results:
---
12:33:17,863 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-3) JBAS015400: Bound mail session [java:jboss/mail/Default]
12:33:18,133 INFO  [org.apache.coyote.http11] (MSC service thread 1-2) JBWEB003001: Coyote HTTP/1.1 initializing on : http-/127.0.0.1:8080
12:33:18,161 INFO  [org.apache.coyote.http11] (MSC service thread 1-2) JBWEB003000: Coyote HTTP/1.1 starting on: http-/127.0.0.1:8080
Create shortcuts in the Start-Menu (y/n) [y]:
---

Expected results:
---
[Host Controller] 12:45:00,790 INFO  [org.jboss.as.host.controller] (server-registration-threads - 1) JBAS010919: Registering server server-one
12:45:00,801 INFO  [org.jboss.as.process.Server:server-two.status] (ProcessController-threads - 3) JBAS012017: Starting process 'Server:server-two'
Checking if server is up

Checking... (1/3)
Application Server started successfully.

Create shortcuts in the Start-Menu (y/n) [y]:
---
Comment 1 Francisco Canas 2013-10-08 11:01:56 EDT
Restored the server started string. Also added a server stopped message used during certain post-install tasks when server has to be brought up and down several times.

http://git.app.eng.bos.redhat.com/jbossas-installer.git/commit/?h=eap-6.2&id=b9252587656e0fd24ccf8b5077207c7ba3b2fa12
Comment 2 Petr Kremensky 2013-10-18 05:05:29 EDT
Verified on EAP 6.2.0.ER6.

Note You need to log in before you can comment on or make changes to this bug.